summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/build-tools/APKBUILD4
-rw-r--r--system/cxref/APKBUILD33
-rw-r--r--system/easy-kernel/0502-muqss-smt-fix.patch14
-rw-r--r--system/easy-kernel/APKBUILD35
-rw-r--r--system/easy-kernel/config-pmmx13
-rw-r--r--system/easy-kernel/config-x86_6415
-rw-r--r--system/fortify-headers/APKBUILD18
-rw-r--r--system/fortify-headers/extension-cpp-fix.patch175
-rw-r--r--system/gdb/APKBUILD6
-rw-r--r--system/gdb/stopcode-lock.patch75
-rw-r--r--system/musl/APKBUILD2
-rw-r--r--system/nspr/APKBUILD6
-rw-r--r--system/nspr/stacksize.patch22
-rw-r--r--system/perl-cpanel-json-xs/APKBUILD4
-rw-r--r--system/perl-test-simple/APKBUILD4
-rw-r--r--system/vim/APKBUILD4
16 files changed, 198 insertions, 232 deletions
diff --git a/system/build-tools/APKBUILD b/system/build-tools/APKBUILD
index 39495ec5b..e5ff48c72 100644
--- a/system/build-tools/APKBUILD
+++ b/system/build-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=build-tools
pkgver=1.0
-pkgrel=7
+pkgrel=8
pkgdesc="Meta-package for user development utilities"
url="https://adelielinux.org/"
arch="noarch"
@@ -11,7 +11,7 @@ depends="bash gettext-tiny gettext-tiny-dev
binutils gcc g++
make
diffutils patch
- fortify-headers linux-headers
+ linux-headers
mawk sed
bzip2 gzip unzip xz
abuild"
diff --git a/system/cxref/APKBUILD b/system/cxref/APKBUILD
new file mode 100644
index 000000000..c629279cb
--- /dev/null
+++ b/system/cxref/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=cxref
+pkgver=1.6e
+pkgrel=0
+pkgdesc="C cross-referencing & documentation tool"
+url="https://www.gedanken.org.uk/software/cxref/"
+arch="all"
+options="!check" # No tests
+license="GPL-2.0+ AND (GPL-3.0+ WITH Bison-exception-2.2) AND LGPL-2.0+"
+depends=""
+makedepends="byacc flex"
+subpackages="$pkgname-doc"
+source="https://www.gedanken.org.uk/software/cxref/download/cxref-$pkgver.tgz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3cc713ed1dab3499c3cb95f9451f2100a90ee2bc86787db93395a977f5a95fa06a9682ae507bde498b326dc462e1f78688890960de64bf9bac48ca9149a70a55 cxref-1.6e.tgz"
diff --git a/system/easy-kernel/0502-muqss-smt-fix.patch b/system/easy-kernel/0502-muqss-smt-fix.patch
new file mode 100644
index 000000000..090b176a4
--- /dev/null
+++ b/system/easy-kernel/0502-muqss-smt-fix.patch
@@ -0,0 +1,14 @@
+diff -Naur --no-dereference linux-4.14-mc13/kernel/sched/MuQSS.c linux-4.14-muqss-resync/kernel/sched/MuQSS.c
+--- linux-4.14-mc13/kernel/sched/MuQSS.c 2018-12-17 13:58:41.877371296 +1100
++++ linux-4.14-muqss-resync/kernel/sched/MuQSS.c 2018-12-27 21:35:04.897927669 +1100
+@@ -188,6 +188,10 @@
+ struct rq *uprq;
+ #endif /* CONFIG_SMP */
+
++#ifdef CONFIG_SCHED_SMT /* This fixes a regression as of 4.14.84 and 4.19.7 which breaks the kernel build if either SMP or MuQSS is enabled */
++DEFINE_STATIC_KEY_FALSE(sched_smt_present);
++#endif
++
+ #include "stats.h"
+
+ #ifndef prepare_arch_switch
diff --git a/system/easy-kernel/APKBUILD b/system/easy-kernel/APKBUILD
index 3e20840fd..2a3903b73 100644
--- a/system/easy-kernel/APKBUILD
+++ b/system/easy-kernel/APKBUILD
@@ -15,8 +15,11 @@ install=""
provides="easy-kernel=$pkgver-r$pkgrel"
subpackages="$_pkgname-modules-$pkgver-mc$pkgrel:modules
$_pkgname-src-$pkgver-mc$pkgrel:src linux-headers:headers"
-source="https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.14.tar.xz
- https://distfiles.adelielinux.org/source/linux-4.14-mc$pkgrel.patch.xz
+_pkgmajver=${pkgver%%.*}
+_pkgminver=${pkgver%.*}
+source="https://cdn.kernel.org/pub/linux/kernel/v${_pkgmajver}.x/linux-${_pkgminver}.tar.xz
+ https://distfiles.adelielinux.org/source/linux-${_pkgminver}-mc$pkgrel.patch.xz
+ 0502-muqss-smt-fix.patch
ast-endianness.patch
config-ppc64
config-ppc
@@ -27,22 +30,30 @@ source="https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.14.tar.xz
kernel.h
uapi-ether.patch
"
-builddir="$srcdir/linux-4.14"
+builddir="$srcdir/linux-${_pkgminver}"
prepare() {
- default_prepare
cd "$srcdir"
- cat linux-4.14-mc$pkgrel.patch.xz | unxz -> linux-4.14-mc$pkgrel.patch
- cd "$builddir"
- patch -Np1 <../linux-4.14-mc$pkgrel.patch
+ cat linux-${_pkgminver}-mc$pkgrel.patch.xz | unxz -> linux-${_pkgminver}-mc$pkgrel.patch
+ patch -Np1 -d "$builddir" <linux-${_pkgminver}-mc$pkgrel.patch
+ default_prepare
cd "$srcdir"
- cp config-$CARCH linux-4.14/.config
- cp -pr linux-4.14 linux-src
+ cp config-$CARCH linux-${_pkgminver}/.config
+ cp -pr linux-${_pkgminver} linux-src
}
build() {
cd "$builddir"
make LDFLAGS=""
+
+ cd "$srcdir/linux-src"
+ make LDFLAGS="" modules_prepare clean
+ cp "$builddir/Module.symvers" .
+
+ # Kernel bug: crtsavres.o is required to build modules, but modules_prepare doesn't create it.
+ if [ $CARCH = ppc ]; then
+ cp "$builddir/arch/powerpc/lib/crtsavres.o" arch/powerpc/lib/
+ fi
}
package() {
@@ -106,13 +117,15 @@ src() {
mkdir -p "$subpkgdir"/usr/src
mv "$srcdir"/linux-src "$subpkgdir"/usr/src/linux-$pkgver-mc$pkgrel
}
+
sha512sums="77e43a02d766c3d73b7e25c4aafb2e931d6b16e870510c22cef0cdb05c3acb7952b8908ebad12b10ef982c6efbe286364b1544586e715cf38390e483927904d8 linux-4.14.tar.xz
bfe606f208894cc572fb98f323e26956c69b4f75febd4a9b500514cbb2aa70bddb2aba05b3f16a5fe52535236b215335f73974324065f80643265f17f281faa6 linux-4.14-mc13.patch.xz
+6ede43cf169e79d8a08f7a9d79bb4bdf15618ec450b42a67a53a75bc5f5cb4d5a8c82d2b95c27a80567999876d103091bc104104f0494ca34707b5ccae5da725 0502-muqss-smt-fix.patch
e41d9111219342ad13367902242444ecdd847a93575c3f9709d6c6a075bc650f4a15be9db1a8798435fc0a0b56d41705829bfe0d2c2d88f8d1c28931e27ef5be ast-endianness.patch
cfa1c2b523875967c42bfd8fcfeeb80b1c4c9887c4399b4767f0ac0525769a9e8c5cddaec831e1adfa546ac2d66f68ef23dc594a286532f4b9890401efd75c67 config-ppc64
1112f6c3fcfd7fdc0ef4d5e85df5d3adea430a9c7b4c2b34508a215f7ba14c863ccd7a5e17f13ed46c518bafec30cfb3ced70c465137c14ef5fc998b6cbcca1f config-ppc
-d72613826070cfab9cea882419c13985109200b387bd96614628e5eadb25f8da8b64c4844e345b724c29f7e6cf0619c649e536cb6cfe552a878d3a977cbb31fe config-x86_64
-40402578479993f78310459dcba783c806e0d2ebf6ad54854ffa338d3332f718ea4e8cf2c2f542584e1672504074122bba70a7ef918be7926f4a97abc20416d3 config-pmmx
+1c5b4365da04a85ac994f123847cc69df0eda772e88b12914cd1e16ea9be62de2a46106f0f0b736f0e7bee746017d49f5671d1277793b5d383258f3d40b562f6 config-x86_64
+69c737ecb6968ca567dfb52335a8a89e147c0b01f92b1e5239bd6d806c10cd7d4225f3cc8a703249020669d3e785df0c1350afda158b0e6c8e70b4805532f07e config-pmmx
231c346e601c1d032a03d6cb19ed3d6e0f538f84d6c9980e3f47236ba9dc3f076ea23f91d68813b7d5c9eea40200f69cef31697f89f514112c09c5762ab2c48a config-aarch64
64486a4f53046a69f727cecd8c39400b50c2d2b15e3b5ca8c18b8249d25990f3a872ec064800ba3d190f9d25b4518899b9ea3675920f487108102856d6beb51e futex-cmpxchg.patch
fdd94b9de7b374f1812dec0f9971c05f5e52177ca4a16c8071daa620c18265b38f656f528e7045a24f30af01f05e53e54546fb0a9e93773cf191866e87de505d kernel.h
diff --git a/system/easy-kernel/config-pmmx b/system/easy-kernel/config-pmmx
index 1484fc1b2..6af94b96d 100644
--- a/system/easy-kernel/config-pmmx
+++ b/system/easy-kernel/config-pmmx
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.14.19-mc4 Kernel Configuration
+# Linux/x86 4.14.88-mc13 Kernel Configuration
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -231,6 +231,7 @@ CONFIG_SLAB_FREELIST_HARDENED=y
CONFIG_SLUB_CPU_PARTIAL=y
CONFIG_SYSTEM_DATA_VERIFICATION=y
CONFIG_PROFILING=y
+CONFIG_HOTPLUG_SMT=y
CONFIG_OPROFILE=m
# CONFIG_OPROFILE_EVENT_MULTIPLEX is not set
CONFIG_HAVE_OPROFILE=y
@@ -267,6 +268,7 @@ CONFIG_HAVE_PERF_REGS=y
CONFIG_HAVE_PERF_USER_STACK_DUMP=y
CONFIG_HAVE_ARCH_JUMP_LABEL=y
CONFIG_HAVE_RCU_TABLE_FREE=y
+CONFIG_HAVE_RCU_TABLE_INVALIDATE=y
CONFIG_ARCH_HAVE_NMI_SAFE_CMPXCHG=y
CONFIG_HAVE_ALIGNED_STRUCT_PAGE=y
CONFIG_HAVE_CMPXCHG_LOCAL=y
@@ -416,7 +418,7 @@ CONFIG_X86_FAST_FEATURE_TESTS=y
CONFIG_X86_MPPARSE=y
CONFIG_X86_BIGSMP=y
# CONFIG_GOLDFISH is not set
-CONFIG_RETPOLINE=n
+# CONFIG_RETPOLINE is not set
# CONFIG_INTEL_RDT is not set
CONFIG_X86_EXTENDED_PLATFORM=y
# CONFIG_X86_GOLDFISH is not set
@@ -499,7 +501,6 @@ CONFIG_HPET_EMULATE_RTC=y
CONFIG_DMI=y
CONFIG_NR_CPUS=8
CONFIG_SCHED_SMT=y
-CONFIG_SMT_NICE=y
CONFIG_SCHED_MC=y
CONFIG_SCHED_MC_PRIO=y
# CONFIG_PREEMPT_NONE is not set
@@ -4161,8 +4162,8 @@ CONFIG_DRM_VGEM=m
CONFIG_DRM_VMWGFX=m
# CONFIG_DRM_VMWGFX_FBCON is not set
CONFIG_DRM_GMA500=m
-# CONFIG_DRM_GMA600 is not set
-# CONFIG_DRM_GMA3600 is not set
+CONFIG_DRM_GMA600=y
+CONFIG_DRM_GMA3600=y
CONFIG_DRM_UDL=m
CONFIG_DRM_AST=m
CONFIG_DRM_MGAG200=m
@@ -5774,7 +5775,6 @@ CONFIG_HAVE_DEBUG_KMEMLEAK=y
CONFIG_ARCH_HAS_DEBUG_VIRTUAL=y
CONFIG_DEBUG_MEMORY_INIT=y
CONFIG_HAVE_DEBUG_STACKOVERFLOW=y
-CONFIG_HAVE_ARCH_KMEMCHECK=y
#
# Debug Lockups and Hangs
@@ -6025,7 +6025,6 @@ CONFIG_CRYPTO_DES=m
# CONFIG_CRYPTO_FCRYPT is not set
# CONFIG_CRYPTO_KHAZAD is not set
# CONFIG_CRYPTO_SALSA20 is not set
-# CONFIG_CRYPTO_SALSA20_586 is not set
# CONFIG_CRYPTO_CHACHA20 is not set
# CONFIG_CRYPTO_SEED is not set
# CONFIG_CRYPTO_SERPENT is not set
diff --git a/system/easy-kernel/config-x86_64 b/system/easy-kernel/config-x86_64
index ba0b3beeb..0724f35f7 100644
--- a/system/easy-kernel/config-x86_64
+++ b/system/easy-kernel/config-x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.14.33-mc6 Kernel Configuration
+# Linux/x86 4.14.88-mc13 Kernel Configuration
#
CONFIG_64BIT=y
CONFIG_X86_64=y
@@ -243,6 +243,7 @@ CONFIG_SLAB_FREELIST_HARDENED=y
CONFIG_SLUB_CPU_PARTIAL=y
CONFIG_SYSTEM_DATA_VERIFICATION=y
CONFIG_PROFILING=y
+CONFIG_HOTPLUG_SMT=y
CONFIG_OPROFILE=m
# CONFIG_OPROFILE_EVENT_MULTIPLEX is not set
CONFIG_HAVE_OPROFILE=y
@@ -279,6 +280,7 @@ CONFIG_HAVE_PERF_REGS=y
CONFIG_HAVE_PERF_USER_STACK_DUMP=y
CONFIG_HAVE_ARCH_JUMP_LABEL=y
CONFIG_HAVE_RCU_TABLE_FREE=y
+CONFIG_HAVE_RCU_TABLE_INVALIDATE=y
CONFIG_ARCH_HAVE_NMI_SAFE_CMPXCHG=y
CONFIG_HAVE_ALIGNED_STRUCT_PAGE=y
CONFIG_HAVE_CMPXCHG_LOCAL=y
@@ -315,7 +317,6 @@ CONFIG_ARCH_MMAP_RND_COMPAT_BITS=8
CONFIG_HAVE_ARCH_COMPAT_MMAP_BASES=y
CONFIG_HAVE_COPY_THREAD_TLS=y
CONFIG_HAVE_STACK_VALIDATION=y
-CONFIG_HAVE_RELIABLE_STACKTRACE=y
# CONFIG_HAVE_ARCH_HASH is not set
# CONFIG_ISA_BUS_API is not set
CONFIG_OLD_SIGSUSPEND3=y
@@ -440,7 +441,7 @@ CONFIG_X86_FAST_FEATURE_TESTS=y
# CONFIG_X86_X2APIC is not set
CONFIG_X86_MPPARSE=y
# CONFIG_GOLDFISH is not set
-CONFIG_RETPOLINE=n
+# CONFIG_RETPOLINE is not set
# CONFIG_INTEL_RDT is not set
CONFIG_X86_EXTENDED_PLATFORM=y
# CONFIG_X86_VSMP is not set
@@ -514,7 +515,6 @@ CONFIG_IOMMU_HELPER=y
# CONFIG_MAXSMP is not set
CONFIG_NR_CPUS=64
CONFIG_SCHED_SMT=y
-CONFIG_SMT_NICE=y
CONFIG_SCHED_MC=y
CONFIG_SCHED_MC_PRIO=y
# CONFIG_PREEMPT_NONE is not set
@@ -4538,8 +4538,8 @@ CONFIG_DRM_VGEM=m
CONFIG_DRM_VMWGFX=m
# CONFIG_DRM_VMWGFX_FBCON is not set
CONFIG_DRM_GMA500=m
-# CONFIG_DRM_GMA600 is not set
-# CONFIG_DRM_GMA3600 is not set
+CONFIG_DRM_GMA600=y
+CONFIG_DRM_GMA3600=y
CONFIG_DRM_UDL=m
CONFIG_DRM_AST=m
CONFIG_DRM_MGAG200=m
@@ -6229,7 +6229,7 @@ CONFIG_UNUSED_SYMBOLS=y
# CONFIG_DEBUG_SECTION_MISMATCH is not set
CONFIG_SECTION_MISMATCH_WARN_ONLY=y
CONFIG_FRAME_POINTER=y
-CONFIG_STACK_VALIDATION=n
+# CONFIG_STACK_VALIDATION is not set
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
CONFIG_MAGIC_SYSRQ=y
CONFIG_MAGIC_SYSRQ_DEFAULT_ENABLE=0x0
@@ -6583,7 +6583,6 @@ CONFIG_CRYPTO_DES=m
# CONFIG_CRYPTO_FCRYPT is not set
# CONFIG_CRYPTO_KHAZAD is not set
# CONFIG_CRYPTO_SALSA20 is not set
-# CONFIG_CRYPTO_SALSA20_X86_64 is not set
# CONFIG_CRYPTO_CHACHA20 is not set
# CONFIG_CRYPTO_CHACHA20_X86_64 is not set
# CONFIG_CRYPTO_SEED is not set
diff --git a/system/fortify-headers/APKBUILD b/system/fortify-headers/APKBUILD
deleted file mode 100644
index 33ee4e317..000000000
--- a/system/fortify-headers/APKBUILD
+++ /dev/null
@@ -1,18 +0,0 @@
-# Contributor: Timo Teräs <timo.teras@iki.fi>
-# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
-pkgname=fortify-headers
-pkgver=1.0
-pkgrel=0
-pkgdesc="libc-agnostic implementation of FORTIFY_SOURCE"
-url="https://git.2f30.org/fortify-headers/"
-arch="noarch"
-options="!check" # No test suite.
-license="0BSD"
-source="https://dl.2f30.org/releases/$pkgname-$pkgver.tar.gz"
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" PREFIX=/usr install
-}
-
-sha512sums="085a725da9a6da0eea732ee77e3a3dc7d3c96bc3344172523db5f1e35391492910a050c15c560912115b2db916c2d6fa37e409e997c53399ee4fee912c5513e8 fortify-headers-1.0.tar.gz"
diff --git a/system/fortify-headers/extension-cpp-fix.patch b/system/fortify-headers/extension-cpp-fix.patch
deleted file mode 100644
index fc7bbb5f8..000000000
--- a/system/fortify-headers/extension-cpp-fix.patch
+++ /dev/null
@@ -1,175 +0,0 @@
-From a29bd89353a05454e2545d52124f9a1a61b4e3e3 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Sat, 23 Jun 2018 17:57:48 -0500
-Subject: [PATCH] Don't use __extension__ in C++ code
-
-A few important notes:
-
-* __extension__ is a GNU C "alternate" keyword, not a C++ keyword.[1]
-
-* __extension__ is designed to work on "expressions"; it does work on
- #include_next in C mode, but it has no effect in C++ mode; the
- warning will still appear, if enabled, even with __extension__
- preceding #include_next. This is because #include_next is not
- considered an expression in C++, so the compiler attaches
- __extension__ to the first expression of the header.
-
-All of this leads us to a build failure while building at least all
-Mozilla software. Moz has an alternate -isystem dir searched before
-/usr/include that overrides some headers, including <features.h>. The
-first statement in each of these headers is a #pragma, and since
-__extension__ is looking for an expression, and #pragma is a "null"
-expression, we end up with the following error:
-
-dist/system_wrappers/features.h:1:9: error: '#pragma' is not allowed here
-
-Since __extension__ has no effect on #include_next in C++ mode anyway,
-and since it can cause breakage, this commit omits __extension__ in C++
-mode.
-
-[1]: https://gcc.gnu.org/onlinedocs/gcc-6.4.0/gcc/Alternate-Keywords.html
----
- include/poll.h | 2 ++
- include/stdio.h | 2 ++
- include/stdlib.h | 4 ++++
- include/string.h | 2 ++
- include/sys/select.h | 2 ++
- include/sys/socket.h | 2 ++
- include/unistd.h | 2 ++
- include/wchar.h | 8 ++++++++
- 8 files changed, 24 insertions(+)
-
-diff --git a/include/poll.h b/include/poll.h
-index 7b42866..24691f1 100644
---- a/include/poll.h
-+++ b/include/poll.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_POLL_H
- #define _FORTIFY_POLL_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <poll.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/stdio.h b/include/stdio.h
-index b67f9ce..a965184 100644
---- a/include/stdio.h
-+++ b/include/stdio.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_STDIO_H
- #define _FORTIFY_STDIO_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <stdio.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/stdlib.h b/include/stdlib.h
-index 7ff5746..ef70995 100644
---- a/include/stdlib.h
-+++ b/include/stdlib.h
-@@ -16,12 +16,16 @@
- #ifndef _FORTIFY_STDLIB_H
- #define _FORTIFY_STDLIB_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <stdlib.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
- #if defined(_XOPEN_SOURCE) || defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <limits.h>
- #endif
-
-diff --git a/include/string.h b/include/string.h
-index ff237b0..43c7485 100644
---- a/include/string.h
-+++ b/include/string.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_STRING_H
- #define _FORTIFY_STRING_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <string.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/sys/select.h b/include/sys/select.h
-index e4e398f..bcee8be 100644
---- a/include/sys/select.h
-+++ b/include/sys/select.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_SYS_SELECT_H
- #define _FORTIFY_SYS_SELECT_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <sys/select.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/sys/socket.h b/include/sys/socket.h
-index 7d3f023..ad6ab2d 100644
---- a/include/sys/socket.h
-+++ b/include/sys/socket.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_SYS_SOCKET_H
- #define _FORTIFY_SYS_SOCKET_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <sys/socket.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/unistd.h b/include/unistd.h
-index d3ab246..71dda84 100644
---- a/include/unistd.h
-+++ b/include/unistd.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_UNISTD_H
- #define _FORTIFY_UNISTD_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <unistd.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/wchar.h b/include/wchar.h
-index 7394598..3cb6f92 100644
---- a/include/wchar.h
-+++ b/include/wchar.h
-@@ -16,13 +16,21 @@
- #ifndef _FORTIFY_WCHAR_H
- #define _FORTIFY_WCHAR_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <limits.h>
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <stdlib.h>
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <string.h>
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <wchar.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
---
-2.15.0
-
diff --git a/system/gdb/APKBUILD b/system/gdb/APKBUILD
index b038ca23f..021848629 100644
--- a/system/gdb/APKBUILD
+++ b/system/gdb/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gdb
pkgver=8.2
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Debugger"
url="https://www.sourceware.org/gdb/"
arch="all"
@@ -17,6 +17,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
ppc-musl.patch
ppc-ptregs.patch
remove-extraneous-include.patch
+ stopcode-lock.patch
"
build() {
@@ -60,4 +61,5 @@ sha512sums="11cc481bebc51eb6db73249ecb62b8c07455cf3db169f4860b3a83114849fbd2b586
986e68275f7692f39b5d8aedeb9f9e88f0e5bebb3f8c7f104933c525d35ca54fc90e18698c1e3e1009e8a188e5e70d6f252cb39e4c75e37db7bf479017e0da32 s390x-use-elf-gdb_fpregset_t.patch
04911f87904b62dd7662435f9182b20485afb29ddb3d6398a9d31fef13495f7b70639c77fdae3a40e2775e270d7cd40d0cfd7ddf832372b506808d33c8301e01 ppc-musl.patch
b75e1c1ee503a1948a7d5b8d90427b5c7d38ded69978056cee0adca222771a5c95ed1ac73127fcae7b795ea94296344eee5fca47e4cd04b418c164a756fb0933 ppc-ptregs.patch
-3ff31774ba78c1208415289566b901debd815da8b53acefe4a0785e7b2bbcff39585a556d44ff2f7d8d639ebc047620b96e72573acae376d8f23aa98dd1fe286 remove-extraneous-include.patch"
+3ff31774ba78c1208415289566b901debd815da8b53acefe4a0785e7b2bbcff39585a556d44ff2f7d8d639ebc047620b96e72573acae376d8f23aa98dd1fe286 remove-extraneous-include.patch
+720d6cbc71d5d4f5cc8955b18a76661688534d409e2beb53e9e2d2322a303fa622e622b583e1f6c50cf3f32b8abe4f5320a6885e7680769c92ef5bb09ef59d1d stopcode-lock.patch"
diff --git a/system/gdb/stopcode-lock.patch b/system/gdb/stopcode-lock.patch
new file mode 100644
index 000000000..6a4e3d855
--- /dev/null
+++ b/system/gdb/stopcode-lock.patch
@@ -0,0 +1,75 @@
+From: Andrew Burgess <andrew.burgess@embecosm.com>
+Date: Tue, 3 Jul 2018 18:02:48 +0000 (+0100)
+Subject: gdb: Avoid using W_STOPCODE(0) as this is ambiguous on MIPS
+X-Git-Tag: users/ARM/embedded-binutils-master-2018q4~1172
+X-Git-Url: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff_plain;h=953473375500a809fbb3eca3efa4dbb670c3a32f
+
+gdb: Avoid using W_STOPCODE(0) as this is ambiguous on MIPS
+
+The MIPS target supports 127 signals, and this can create an ambiguity
+in process wait statuses. A status value of 0x007f could potentially
+indicate a process that has exited with signal 127, or a process that
+has stopped with signal 0.
+
+In uClibc-ng the interpretation of 0x007f is that the process has
+exited with signal 127 rather than stopped with signal 0, and so,
+WIFSTOPPED (W_STOPCODE (0)) will be false rather than true as it would
+be on most other platforms.
+
+Given that it's pretty easy to avoid using W_STOPCODE (0), lets do that.
+
+gdb/ChangeLog:
+
+ * linux-nat.c (linux_nat_target::follow_fork): Avoid using
+ 'W_STOPCODE (0)' as this could be ambiguous.
+---
+
+diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
+index 86d3dfd..d2c88ad 100644
+--- a/gdb/linux-nat.c
++++ b/gdb/linux-nat.c
+@@ -445,7 +445,6 @@ linux_nat_target::follow_fork (int follow_child, int detach_fork)
+ if (!follow_child)
+ {
+ struct lwp_info *child_lp = NULL;
+- int status = W_STOPCODE (0);
+ int has_vforked;
+ ptid_t parent_ptid, child_ptid;
+ int parent_pid, child_pid;
+@@ -465,6 +464,8 @@ linux_nat_target::follow_fork (int follow_child, int detach_fork)
+ /* Detach new forked process? */
+ if (detach_fork)
+ {
++ int child_stop_signal = 0;
++ bool detach_child = true;
+ struct cleanup *old_chain = make_cleanup (delete_lwp_cleanup,
+ child_lp);
+
+@@ -484,18 +485,24 @@ linux_nat_target::follow_fork (int follow_child, int detach_fork)
+ if (!gdbarch_software_single_step_p (target_thread_architecture
+ (parent_ptid)))
+ {
++ int status;
++
+ linux_disable_event_reporting (child_pid);
+ if (ptrace (PTRACE_SINGLESTEP, child_pid, 0, 0) < 0)
+ perror_with_name (_("Couldn't do single step"));
+ if (my_waitpid (child_pid, &status, 0) < 0)
+ perror_with_name (_("Couldn't wait vfork process"));
++ else
++ {
++ detach_child = WIFSTOPPED (status);
++ child_stop_signal = WSTOPSIG (status);
++ }
+ }
+
+- if (WIFSTOPPED (status))
++ if (detach_child)
+ {
+- int signo;
++ int signo = child_stop_signal;
+
+- signo = WSTOPSIG (status);
+ if (signo != 0
+ && !signal_pass_state (gdb_signal_from_host (signo)))
+ signo = 0;
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index 1ab117c16..bffa25154 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=musl
pkgver=1.1.21
-pkgrel=1
+pkgrel=3
pkgdesc="System library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
diff --git a/system/nspr/APKBUILD b/system/nspr/APKBUILD
index a6da52de1..bf0c907e8 100644
--- a/system/nspr/APKBUILD
+++ b/system/nspr/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=nspr
pkgver=4.20
-pkgrel=0
+pkgrel=1
pkgdesc="Netscape Portable Runtime"
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR"
arch="all"
@@ -14,6 +14,7 @@ makedepends="autoconf automake"
subpackages="$pkgname-dev"
source="http://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v$pkgver/src/nspr-$pkgver.tar.gz
fix-getproto.patch
+ stacksize.patch
"
prepare() {
@@ -61,4 +62,5 @@ package() {
}
sha512sums="22fdf7627f450b0594ebccaee170098e1a8cd0f429fd44816f1322756002ced3d69cf686c3f69f7cb30b8132d3605a9fce5457ab99d0002e6af11a3408a5c949 nspr-4.20.tar.gz
-ee654f609a90b9a95c1901ad1d56cdef7cce8bca9efc092198607944f142f8fec924b13219ca6663facd0f0d59b671b8b3de58ab3449c4c863d42e2937f02184 fix-getproto.patch"
+ee654f609a90b9a95c1901ad1d56cdef7cce8bca9efc092198607944f142f8fec924b13219ca6663facd0f0d59b671b8b3de58ab3449c4c863d42e2937f02184 fix-getproto.patch
+1f694fc151f6578080449e3aa999c520486bbe117b8237150966ec43092db4156e81412ac889045e0c0c3bf65d459af5bdc1cf19c9fa3dab120405a60732f15a stacksize.patch"
diff --git a/system/nspr/stacksize.patch b/system/nspr/stacksize.patch
new file mode 100644
index 000000000..c2fcecd68
--- /dev/null
+++ b/system/nspr/stacksize.patch
@@ -0,0 +1,22 @@
+set a minimum stack size on ppc64 to prevent crashes
+
+Firefox, a user of nspr, attempts to set a stack size of 32k in its
+JS watchdog, which the pthreads impl doesn't like and fails.
+
+Coincidentally, nspr here is compiled with debug on, which means it has
+assertions turned on; under normal circumstances, those would be disabled,
+the stack size set call would fail and everything would fall back on the
+default 2M stacksize, but it would still be wrong - therefore, establish
+a minimum, just like for aarch64.
+
+--- nspr-4.20/nspr/pr/include/md/_linux.h.old 2018-08-28 12:42:28.000000000 +0000
++++ nspr-4.20/nspr/pr/include/md/_linux.h 2019-02-18 17:35:30.380000000 +0000
+@@ -71,7 +71,7 @@
+ #define _MD_DEFAULT_STACK_SIZE 65536L
+ #define _MD_MMAP_FLAGS MAP_PRIVATE
+
+-#if defined(__aarch64__) || defined(__mips__)
++#if defined(__aarch64__) || defined(__mips__) || defined(__powerpc64__)
+ #define _MD_MINIMUM_STACK_SIZE 0x20000
+ #endif
+
diff --git a/system/perl-cpanel-json-xs/APKBUILD b/system/perl-cpanel-json-xs/APKBUILD
index 76e9a74a9..3792720b6 100644
--- a/system/perl-cpanel-json-xs/APKBUILD
+++ b/system/perl-cpanel-json-xs/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-cpanel-json-xs
_pkgreal=Cpanel-JSON-XS
-pkgver=4.08
+pkgver=4.09
pkgrel=0
pkgdesc="cPanel's fork of JSON::XS, fast and correct serialising"
url="https://metacpan.org/release/Cpanel-JSON-XS"
@@ -40,4 +40,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="7236923791b244e022cea00f3c8697905a8187edddaf0b197ee6f8a4afe958c42ea37f655e0db8e4c66a07427b7888e68ae1dc08849ef7cbb518155b2d9c65f5 Cpanel-JSON-XS-4.08.tar.gz"
+sha512sums="9d0771129a473b696bcfd502303a88e8e97f0dc2cf2b97003328edf72182400b8c07a2f5cf120f102c32a04118d4530f3d7da369c9b063554d2cfc0feddbb6aa Cpanel-JSON-XS-4.09.tar.gz"
diff --git a/system/perl-test-simple/APKBUILD b/system/perl-test-simple/APKBUILD
index 1462197f8..ac80247c5 100644
--- a/system/perl-test-simple/APKBUILD
+++ b/system/perl-test-simple/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-simple
_pkgreal=Test-Simple
-pkgver=1.302160
+pkgver=1.302162
pkgrel=0
pkgdesc="Basic utilities for writing Perl tests"
url="https://metacpan.org/release/Test-Simple"
@@ -47,4 +47,4 @@ doc() {
replaces="perl-doc"
}
-sha512sums="3df744efbf5e2bf1b03849f35bec32f0b0546efbe968e38ed55a472d92f2b2f5a7cf63e82d6fda7ec2406c403c053a32285d29dcf21d28030a924bc751e16548 Test-Simple-1.302160.tar.gz"
+sha512sums="1e8ac18986f4e8ae44f385a4db025adc714dd355b8590472392468a8865a2a21d0a30484c196f4cb31fcb1fcff85e7e06f8402931d8f9b04fea4139399aad116 Test-Simple-1.302162.tar.gz"
diff --git a/system/vim/APKBUILD b/system/vim/APKBUILD
index 13dff8ef9..9c75b2621 100644
--- a/system/vim/APKBUILD
+++ b/system/vim/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=vim
-pkgver=8.1.0829
+pkgver=8.1.0952
pkgrel=0
pkgdesc="advanced text editor"
url="http://www.vim.org"
@@ -81,6 +81,6 @@ vimdiff() {
mv "$pkgdir"/usr/bin/vimdiff "$subpkgdir"/usr/bin
}
-sha512sums="c5ae44a6ad45092abc1079b0543af3c34d49823a95f96bbb8dbe3f5426556ee9dbf78d2bda747286527977dafef7e6051a670d0095456263e853d424ddb2466c vim-8.1.0829.tar.gz
+sha512sums="485d839901b3d1fc8efcc035991d5f34849f6d05d9c556dcf5b2918cd01e7f7b490cd0a7eb976c7577adb41962dceea4552474103f0b3c7807311d07f8158bd1 vim-8.1.0952.tar.gz
12ee3f96c94d74215159fba379ed61907ec5982a9f1643575dcb7c3d5e30824665d683de95f97b5067718b3f2a1238fb7534a70803bc170614498ad026f352d8 vimrc
16026a3ed3e080b3f8281948579ab678e9acd724ad594463279712fbf1024bcd923155a133bd08118848d2c6cdf11c69489d85b1c7438f60b4c279094714d181 no-default-mouse.patch"