summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch57
-rw-r--r--system/apk-tools/APKBUILD4
-rw-r--r--system/apk-tools/list.patch22
-rw-r--r--system/apk-tools/openssl-compat.patch11
-rw-r--r--system/bc/APKBUILD12
-rw-r--r--system/curl/APKBUILD4
-rw-r--r--system/gdb/APKBUILD17
-rw-r--r--system/gdb/arm64.patch44
-rw-r--r--system/perl-cpanel-json-xs/APKBUILD4
-rw-r--r--system/perl-io-socket-ssl/APKBUILD4
-rw-r--r--system/perl-json/APKBUILD4
-rw-r--r--system/perl-libwww/APKBUILD9
-rw-r--r--system/perl-lwp-mediatypes/APKBUILD12
-rw-r--r--system/psmisc/APKBUILD5
-rw-r--r--system/psmisc/musl_ptregs.patch6
-rw-r--r--system/vim/APKBUILD4
16 files changed, 113 insertions, 106 deletions
diff --git a/system/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch b/system/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
deleted file mode 100644
index 107676e93..000000000
--- a/system/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 0dcbd933c8d3d305395a99b7b1690a187ce5ec8c Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Wed, 21 Feb 2018 15:35:53 +0000
-Subject: [PATCH] solver: allow names with only one provider to be autoselected
- regardless of priority
-
----
- src/solver.c | 5 +++--
- test/provides.repo | 9 ++++++++-
- 2 files changed, 11 insertions(+), 3 deletions(-)
-
-diff --git a/src/solver.c b/src/solver.c
-index 91e5958..d27a7a3 100644
---- a/src/solver.c
-+++ b/src/solver.c
-@@ -671,11 +671,12 @@ static void select_package(struct apk_solver_state *ss, struct apk_name *name)
- (!p->pkg->ss.iif_triggered ||
- !p->pkg->ss.tag_ok))
- continue;
-- /* Virtual packages without provider_priority cannot be autoselected */
-+ /* Virtual packages without provider_priority cannot be autoselected,
-+ * unless there is only one provider */
- if (p->version == &apk_null_blob &&
- p->pkg->name->auto_select_virtual == 0 &&
- p->pkg->name->ss.requirers == 0 &&
-- p->pkg->provider_priority == 0)
-+ (p->pkg->provider_priority == 0 && name->providers->num > 1))
- continue;
- if (compare_providers(ss, p, &chosen) > 0)
- chosen = *p;
-diff --git a/test/provides.repo b/test/provides.repo
-index 58bd416..358151e 100644
---- a/test/provides.repo
-+++ b/test/provides.repo
-@@ -82,7 +82,7 @@ P:conflicted-provider-b
- V:0.1
- S:1
- I:1
--p:conflicted-provider
-+p:conflicted-provider conflicted-provider-2
-
- C:Q1EyN5AdpAOBJWKMR89ppC66ccccj=
- P:conflicted-dep
-@@ -104,3 +104,10 @@ V:0.1
- S:1
- I:1
- p:self-provide
-+
-+C:Q1EyN5AdpAOBJWKMR89ppC66eeeej=
-+P:conflicted-dep-2
-+V:0.1
-+S:1
-+I:1
-+D:conflicted-provider-2
---
-2.16.1
-
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index c6b0b479a..d35a6b2f1 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=apk-tools
pkgver=2.10.3
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine Package Keeper - package manager"
url="https://git.alpinelinux.org/cgit/apk-tools/"
arch="all"
@@ -13,6 +13,7 @@ makedepends_host="zlib-dev openssl openssl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-static"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
+ list.patch
pmmx.patch
"
@@ -68,4 +69,5 @@ static() {
}
sha512sums="1b190cfd04c69369bd4f2b708d4df0f8cf2937e1580c95138fd2c2257e7604d015deaca10a9fe0da6742981caadb6b067c15e417a1951866f781b8a5c71c98ee apk-tools-2.10.3.tar.xz
+1c1bd86c47273f23c9c12639fbfa2978c3a1104cb8b30be7e92d1b1d0f863c28efe9153612d62402616dabc3e713877125f56798c908470937d0fa567db948db list.patch
746d00ce2af554a25db7ecea2b0a4d8f7399d2560efb6bf59ea144012d0163d3e0bad84c799bd706e8be6c0a543d4e35728d6beb269fddbbea626384009129cb pmmx.patch"
diff --git a/system/apk-tools/list.patch b/system/apk-tools/list.patch
new file mode 100644
index 000000000..ea264e0fa
--- /dev/null
+++ b/system/apk-tools/list.patch
@@ -0,0 +1,22 @@
+diff --git a/src/list.c b/src/list.c
+index e285e3f..dcbaeea 100644
+--- a/src/list.c
++++ b/src/list.c
+@@ -61,7 +61,7 @@ static int is_orphaned(const struct apk_name *name)
+ /* repo 1 is always installed-db, so if other bits are set it means the package is available somewhere
+ * (either cache or in a proper repo)
+ */
+- return (repos & ~BIT(1)) == 0;
++ return (repos & ~BIT(0)) == 0;
+ }
+
+ /* returns the currently installed package if there is a newer package that satisfies `name` */
+@@ -144,7 +144,7 @@ static void filter_package(const struct apk_package *pkg, const struct list_ctx
+ if (ctx->orphaned && !is_orphaned(pkg->name))
+ return;
+
+- if (ctx->available && pkg->repos == BIT(1))
++ if (ctx->available && pkg->repos == BIT(0))
+ return;
+
+ if (ctx->upgradable && !is_upgradable(pkg->name, pkg))
diff --git a/system/apk-tools/openssl-compat.patch b/system/apk-tools/openssl-compat.patch
deleted file mode 100644
index cdafefd05..000000000
--- a/system/apk-tools/openssl-compat.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- apk-tools-2.8.1/libfetch/common.c.old 2017-10-27 08:12:05.000000000 -0500
-+++ apk-tools-2.8.1/libfetch/common.c 2017-11-11 22:37:18.661697875 -0600
-@@ -504,7 +504,7 @@
-
- SSL_load_error_strings();
-
-- conn->ssl_meth = TLS_client_method();
-+ conn->ssl_meth = SSLv23_client_method();
- conn->ssl_ctx = SSL_CTX_new(conn->ssl_meth);
- SSL_CTX_set_mode(conn->ssl_ctx, SSL_MODE_AUTO_RETRY);
-
diff --git a/system/bc/APKBUILD b/system/bc/APKBUILD
index d234fa61f..0109fab0e 100644
--- a/system/bc/APKBUILD
+++ b/system/bc/APKBUILD
@@ -1,20 +1,20 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=bc
-pkgver=1.1.4
+pkgver=1.2.3
pkgrel=0
pkgdesc="An arbitrary precision numeric processing language (calculator)"
url="https://github.com/gavinhoward/bc"
arch="all"
-license="BSD-0-Clause"
+license="BSD-2-Clause"
depends=""
makedepends=""
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-lang"
source="https://github.com/gavinhoward/bc/releases/download/${pkgver/_/-}/bc-${pkgver/_/-}.tar.xz"
builddir="$srcdir"/$pkgname-${pkgver/_/-}
build() {
- PREFIX="/usr" ./configure.sh -g -G -O3
+ PREFIX="/usr" DESTDIR="$pkgdir" ./configure.sh -g -G -O3
make
}
@@ -23,7 +23,7 @@ check() {
}
package() {
- make PREFIX="/usr" DESTDIR="$pkgdir" install
+ make install
}
-sha512sums="fa67325cc3cb5df7513e6d0ae74d3476d7d9e87722db2f24d0cf0781622f02ec99e6ab27d3e2d57866830dd18dc43eb3c52d460be6c6ec0260ce2bad7765d7aa bc-1.1.4.tar.xz"
+sha512sums="5277177a0627b00d8022f37060f6496312ae0f25e41521b5d7276c0e177f1ee7605f148b0bdee1f526fbc5d00e36a2c1ecbf4f808978e6f55e2745f327bd3bdd bc-1.2.3.tar.xz"
diff --git a/system/curl/APKBUILD b/system/curl/APKBUILD
index 229275904..1b53bd0a5 100644
--- a/system/curl/APKBUILD
+++ b/system/curl/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Maintainer:
pkgname=curl
-pkgver=7.64.0
+pkgver=7.64.1
pkgrel=0
pkgdesc="An URL retrival utility and library"
url="https://curl.haxx.se"
@@ -101,4 +101,4 @@ libcurl() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr
}
-sha512sums="953f1f5336ce5dfd1b9f933624432d401552d91ee02d39ecde6f023c956f99ec6aae8d7746d7c34b6eb2d6452f114e67da4e64d9c8dd90b7644b7844e7b9b423 curl-7.64.0.tar.xz"
+sha512sums="1629ba154691bf9d936e0bce69ec8fb54991a40d34bc16ffdfb117f91e3faa93164154fc9ae9043e963955862e69515018673b7239f2fd625684a59cdd1db81c curl-7.64.1.tar.xz"
diff --git a/system/gdb/APKBUILD b/system/gdb/APKBUILD
index 021848629..a8ce6acfd 100644
--- a/system/gdb/APKBUILD
+++ b/system/gdb/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gdb
-pkgver=8.2
-pkgrel=1
+pkgver=8.2.1
+pkgrel=0
pkgdesc="The GNU Debugger"
url="https://www.sourceware.org/gdb/"
arch="all"
options="!check" # thousands of test failures
license="GPL-3.0+"
-depends=
+depends=""
makedepends="ncurses-dev expat-dev texinfo python3-dev
zlib-dev autoconf automake libtool linux-headers perl"
subpackages="$pkgname-doc $pkgname-lang"
@@ -18,6 +18,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
ppc-ptregs.patch
remove-extraneous-include.patch
stopcode-lock.patch
+ arm64.patch
"
build() {
@@ -27,15 +28,10 @@ build() {
--host=$CHOST
--prefix=/usr
--target=$CTARGET
- --with-build-sysroot=$CBUILDROOT
- --with-python=/usr/bin/python3
--disable-werror
--mandir=/usr/share/man
--infodir=/usr/share/info"
- # use system zlib if not cross compiling
- [ "$CBUILD" = "$CHOST" ] && _config="$_config --with-system-zlib"
-
# avoid generation of mangled and non-mangled objects on ppc64
[ "$CARCH" = ppc64le ] && _config="$_config --enable-build-with-cxx=no"
@@ -57,9 +53,10 @@ package() {
rm -rf "$pkgdir"/usr/lib
}
-sha512sums="11cc481bebc51eb6db73249ecb62b8c07455cf3db169f4860b3a83114849fbd2b5860a2db64488ba6c5909cf07b255c04770f1e36059eae6bee16d2a3581be90 gdb-8.2.tar.xz
+sha512sums="2aa81cfd389bb48c35d7d9f95cc10e88b4f7ad4597bdde0f8f1fd312f60f10d9fb2cc6e5a9355227d89ff328f7feb0fc411a69394560cafeb9fa75d35d896d11 gdb-8.2.1.tar.xz
986e68275f7692f39b5d8aedeb9f9e88f0e5bebb3f8c7f104933c525d35ca54fc90e18698c1e3e1009e8a188e5e70d6f252cb39e4c75e37db7bf479017e0da32 s390x-use-elf-gdb_fpregset_t.patch
04911f87904b62dd7662435f9182b20485afb29ddb3d6398a9d31fef13495f7b70639c77fdae3a40e2775e270d7cd40d0cfd7ddf832372b506808d33c8301e01 ppc-musl.patch
b75e1c1ee503a1948a7d5b8d90427b5c7d38ded69978056cee0adca222771a5c95ed1ac73127fcae7b795ea94296344eee5fca47e4cd04b418c164a756fb0933 ppc-ptregs.patch
3ff31774ba78c1208415289566b901debd815da8b53acefe4a0785e7b2bbcff39585a556d44ff2f7d8d639ebc047620b96e72573acae376d8f23aa98dd1fe286 remove-extraneous-include.patch
-720d6cbc71d5d4f5cc8955b18a76661688534d409e2beb53e9e2d2322a303fa622e622b583e1f6c50cf3f32b8abe4f5320a6885e7680769c92ef5bb09ef59d1d stopcode-lock.patch"
+720d6cbc71d5d4f5cc8955b18a76661688534d409e2beb53e9e2d2322a303fa622e622b583e1f6c50cf3f32b8abe4f5320a6885e7680769c92ef5bb09ef59d1d stopcode-lock.patch
+8bba2fdf6a53ed61cad2c1ec58e19014818d2481531008c024a0d863ea0bf7c466592cfee7e1bee56262df44cc557573a7f472b3fa8afcb46fe0220192e86091 arm64.patch"
diff --git a/system/gdb/arm64.patch b/system/gdb/arm64.patch
new file mode 100644
index 000000000..a718a8c6a
--- /dev/null
+++ b/system/gdb/arm64.patch
@@ -0,0 +1,44 @@
+The signal definitions of musl and gdb collide
+
+The kernel defines "struct sigcontext" in asm/sigcontext.h and musl libc
+defines it in signal.h which collides.
+Kernel 4.14 misses the definitions of struct user_sve_header so we still
+have to use the aarch64-sve-linux-sigcontext.h header file which also
+provides that and make sure aarch64-sve-linux-sigcontext.h does not
+provide the same headers as the kernel or musl.
+
+--- a/gdb/nat/aarch64-sve-linux-ptrace.h
++++ b/gdb/nat/aarch64-sve-linux-ptrace.h
+@@ -20,12 +20,12 @@
+ #ifndef AARCH64_SVE_LINUX_PTRACE_H
+ #define AARCH64_SVE_LINUX_PTRACE_H
+
+-#include <asm/sigcontext.h>
++#include <signal.h>
+ #include <sys/utsname.h>
+ #include <sys/ptrace.h>
+ #include <asm/ptrace.h>
+
+-#ifndef SVE_SIG_ZREGS_SIZE
++#ifndef SVE_PT_REGS_SVE
+ #include "aarch64-sve-linux-sigcontext.h"
+ #endif
+
+--- a/gdb/nat/aarch64-sve-linux-sigcontext.h
++++ b/gdb/nat/aarch64-sve-linux-sigcontext.h
+@@ -19,6 +19,7 @@
+ #ifndef AARCH64_SVE_LINUX_SIGCONTEXT_H
+ #define AARCH64_SVE_LINUX_SIGCONTEXT_H
+
++#ifndef SVE_MAGIC
+ #define SVE_MAGIC 0x53564501
+
+ struct sve_context {
+@@ -128,6 +129,7 @@ struct sve_context {
+ (SVE_SIG_FFR_OFFSET(vq) + SVE_SIG_FFR_SIZE(vq) - SVE_SIG_REGS_OFFSET)
+
+ #define SVE_SIG_CONTEXT_SIZE(vq) (SVE_SIG_REGS_OFFSET + SVE_SIG_REGS_SIZE(vq))
++#endif
+
+ /* SVE/FP/SIMD state (NT_ARM_SVE) */
+
diff --git a/system/perl-cpanel-json-xs/APKBUILD b/system/perl-cpanel-json-xs/APKBUILD
index 6caa3779d..08b33c3e9 100644
--- a/system/perl-cpanel-json-xs/APKBUILD
+++ b/system/perl-cpanel-json-xs/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-cpanel-json-xs
_pkgreal=Cpanel-JSON-XS
-pkgver=4.09
+pkgver=4.11
pkgrel=0
pkgdesc="cPanel's fork of JSON::XS, fast and correct serialising"
url="https://metacpan.org/release/Cpanel-JSON-XS"
@@ -40,4 +40,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="9d0771129a473b696bcfd502303a88e8e97f0dc2cf2b97003328edf72182400b8c07a2f5cf120f102c32a04118d4530f3d7da369c9b063554d2cfc0feddbb6aa Cpanel-JSON-XS-4.09.tar.gz"
+sha512sums="a14fe211b769184c28d946b9e88d9a380331d6a16c67a0f286fb4bf0f25e2a3b80f3df907bdf1a7eceaa8a34e69f13b3296cc135bc1ea2d2fcba6355dcf88579 Cpanel-JSON-XS-4.11.tar.gz"
diff --git a/system/perl-io-socket-ssl/APKBUILD b/system/perl-io-socket-ssl/APKBUILD
index 225ffb38d..ab1804d91 100644
--- a/system/perl-io-socket-ssl/APKBUILD
+++ b/system/perl-io-socket-ssl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-io-socket-ssl
_pkgreal=IO-Socket-SSL
-pkgver=2.060
+pkgver=2.066
pkgrel=0
pkgdesc="Perl module implementing SSL/TLS with IO::Socket interface"
url="https://metacpan.org/release/IO-Socket-SSL"
@@ -37,4 +37,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="1a1e29f8a4b912bd3643509356c66b3a567ae41bb0ac9eb30f6ca97eb68bf9507e20c0fb8512f5dfd309accd6cfba61811b8d637f5e991aaa0a250a906fcb95c IO-Socket-SSL-2.060.tar.gz"
+sha512sums="2a15f6d65f276ad4eae33139ae7af4c891d4c9e5f6aa65f45e51bfa02c85e8367a275bd33c73ece1b47b9d18eadc59e65fe1c584f9ccd3c7655948710fb4a57a IO-Socket-SSL-2.066.tar.gz"
diff --git a/system/perl-json/APKBUILD b/system/perl-json/APKBUILD
index 1c5f62674..ee036d859 100644
--- a/system/perl-json/APKBUILD
+++ b/system/perl-json/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-json
_pkgreal=JSON
-pkgver=4.01
+pkgver=4.02
pkgrel=0
pkgdesc="Perl module implementing a JSON encoder/decoder"
url="https://metacpan.org/release/JSON"
@@ -32,4 +32,4 @@ package() {
find "$pkgdir" -name .packlist -delete
}
-sha512sums="95d38b994fc0452ad2a111cf640e0860f028039fa19c636b0c8facfd9a42851ec7f1917a2bef6a2b27d0990513329f6051ad7b85ecbe02b755200762c7331088 JSON-4.01.tar.gz"
+sha512sums="4af44478cd1dac1755768e5211fe86f0086150157393ff2075def7cf6a394fe11e8e35f369f2abc0470373efc8021e941c59ace9a92dfcd50740f924c747d95a JSON-4.02.tar.gz"
diff --git a/system/perl-libwww/APKBUILD b/system/perl-libwww/APKBUILD
index 78eee2e80..65aa812d8 100644
--- a/system/perl-libwww/APKBUILD
+++ b/system/perl-libwww/APKBUILD
@@ -2,7 +2,10 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-libwww
_realname=libwww-perl
-pkgver=6.36
+_author1=O
+_author2=${_author1}A
+_author=${_author2}LDERS
+pkgver=6.38
pkgrel=0
pkgdesc="Perl module - World Wide Web library"
url="https://metacpan.org/release/libwww-perl"
@@ -15,7 +18,7 @@ depends="perl-http-date perl-http-cookies perl-net-http perl-http-daemon
makedepends="perl-dev perl-test-fatal perl-test-requiresinternet"
install=
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://cpan.metacpan.org/authors/id/E/ET/ETHER/libwww-perl-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://cpan.metacpan.org/authors/id/$_author1/$_author2/$_author/libwww-perl-$pkgver.tar.gz"
builddir="$srcdir/$_realname-$pkgver"
build() {
@@ -36,4 +39,4 @@ package() {
find "$pkgdir" -name perllocal.pod -delete
}
-sha512sums="049da6dbd57dbfbceec878c1deb80e9eb3d45c0cc29535eb15804eb5038e0437122cd70ed92ed4313d1f1940cc34baa7a8f367401fb984c0f3688c31adf2c483 perl-libwww-6.36.tar.gz"
+sha512sums="7f1332ea3b72ce01d4e20532cefa9229d0727c56d1a068f76983dd39a7d292b0a77fde93946ca16f2969e1a55b8ce8ba4cf22cd74bfe8cfda92204e3549b5cd0 perl-libwww-6.38.tar.gz"
diff --git a/system/perl-lwp-mediatypes/APKBUILD b/system/perl-lwp-mediatypes/APKBUILD
index 6b4868091..b1042949d 100644
--- a/system/perl-lwp-mediatypes/APKBUILD
+++ b/system/perl-lwp-mediatypes/APKBUILD
@@ -2,18 +2,22 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-lwp-mediatypes
_realname=LWP-MediaTypes
-pkgver=6.02
-pkgrel=2
+_author1=O
+_author2=${_author1}A
+_author=${_author2}LDERS
+pkgver=6.04
+pkgrel=0
pkgdesc="Perl module - guess media type for a file or a URL"
url="https://metacpan.org/release/LWP-MediaTypes"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev"
+checkdepends="perl-test-fatal"
install=
replaces="perl-libwww"
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_realname-$pkgver.tar.gz"
+source="https://search.cpan.org/CPAN/authors/id/$_author1/$_author2/$_author/$_realname-$pkgver.tar.gz"
builddir="$srcdir/$_realname-$pkgver"
build() {
@@ -34,4 +38,4 @@ package() {
find "$pkgdir" -name perllocal.pod -delete
}
-sha512sums="b2ad33fb2c6dd7afaa9b8dd2ed6a15b2ecc35d13bcdf5297ce1632ea77406def0840a24c5213187707b665f28cc9bbea5774bfd1a4070d1f6192e904f707b94e LWP-MediaTypes-6.02.tar.gz"
+sha512sums="0610627ef3efdfde3c89bad273931c9cbde5c6da0bd782d59ce26dc4445cd538be9041d722f08206d96d69d5e3643b15150ef29b9e92e3968833f2ae1b6dc53f LWP-MediaTypes-6.04.tar.gz"
diff --git a/system/psmisc/APKBUILD b/system/psmisc/APKBUILD
index 461b6bc6d..8eb5be7d5 100644
--- a/system/psmisc/APKBUILD
+++ b/system/psmisc/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-
pkgname=psmisc
pkgver=23.1
-pkgrel=0
+pkgrel=1
pkgdesc="Miscellaneous utilities that use the proc filesystem"
url="https://gitlab.com/psmisc/psmisc"
arch="all"
@@ -58,4 +57,4 @@ package() {
sha512sums="636f33b628f07599c7a08d0fe0e084469647e2b03046f9c220f6a24475ab1d5dd07db2501bc1a581ca68c72c212367b5dab8b44edfe477a70bfc8740af2b1365 psmisc-23.1.tar.bz2
a68c75eb3c66a9df0d4e574a9439eeed0cd2dc97b3cad3fcd8b945619c2ec238b73bf479d1b55ddd4821471cd8934ee1fbc7871c92de7ef72c3d3f989ab62c9f dont-underlink-peekfd.patch
b16139606e1ccaebd94b7b7a14f49f530b180f1fd24338008e4c4d48761b57953458c46e57b0f7ec191353514f68126f79c281875c4cd56ed2f1220ace131ce1 fix-peekfd-on-ppc.patch
-73dec9791e8cdb85cd3d9ef9be4d16e0fef481c6edc334ed9e954829444b1a92b87f7a3a2e6c1d09ac207bed828f214f5f2a95caa66540a7f2a6c58a6b8f6f2c musl_ptregs.patch"
+57e3ebf427bae9d3ef5b40be1cbc29743009720a75369c91d338f7634fea5bf522f20ec54404b99f3a39e2c4c146c40baee2b22f68e5ede76678d488fde00db5 musl_ptregs.patch"
diff --git a/system/psmisc/musl_ptregs.patch b/system/psmisc/musl_ptregs.patch
index 29fee6a2a..280181a58 100644
--- a/system/psmisc/musl_ptregs.patch
+++ b/system/psmisc/musl_ptregs.patch
@@ -7,13 +7,17 @@ Index: psmisc-22.21/src/peekfd.c
===================================================================
--- a/src/peekfd.c.old
+++ b/src/peekfd.c
-@@ -27,7 +27,9 @@
+@@ -27,7 +27,13 @@
#include <sys/types.h>
#include <sys/wait.h>
#include <sys/syscall.h>
++#ifdef __PPC__
+#define pt_regs uapi_pt_regs
++#endif
#include <asm/ptrace.h>
++#ifdef __PPC__
+#undef pt_regs
++#endif
#include <byteswap.h>
#include <endian.h>
#include <sys/user.h>
diff --git a/system/vim/APKBUILD b/system/vim/APKBUILD
index bf29cc167..a6d0bbaac 100644
--- a/system/vim/APKBUILD
+++ b/system/vim/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=vim
-pkgver=8.1.0952
+pkgver=8.1.1073
pkgrel=0
pkgdesc="advanced text editor"
url="https://www.vim.org"
@@ -81,6 +81,6 @@ vimdiff() {
mv "$pkgdir"/usr/bin/vimdiff "$subpkgdir"/usr/bin
}
-sha512sums="485d839901b3d1fc8efcc035991d5f34849f6d05d9c556dcf5b2918cd01e7f7b490cd0a7eb976c7577adb41962dceea4552474103f0b3c7807311d07f8158bd1 vim-8.1.0952.tar.gz
+sha512sums="74d13063853677aaff795925414baa293819ccd20e3deb7013c134b42434e8abd14db1645116b20081f80bcb3dfd9a1e0c6b210ed9af62a4cf19c183025c9779 vim-8.1.1073.tar.gz
12ee3f96c94d74215159fba379ed61907ec5982a9f1643575dcb7c3d5e30824665d683de95f97b5067718b3f2a1238fb7534a70803bc170614498ad026f352d8 vimrc
16026a3ed3e080b3f8281948579ab678e9acd724ad594463279712fbf1024bcd923155a133bd08118848d2c6cdf11c69489d85b1c7438f60b4c279094714d181 no-default-mouse.patch"