summaryrefslogtreecommitdiff
path: root/user/acpilight/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/acpilight/APKBUILD')
-rw-r--r--user/acpilight/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/acpilight/APKBUILD b/user/acpilight/APKBUILD
new file mode 100644
index 000000000..97956accd
--- /dev/null
+++ b/user/acpilight/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=acpilight
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Control backlight brightness level"
+url="https://github.com/wavexx/acpilight"
+arch="noarch"
+license="GPL-3.0"
+depends="eudev python3"
+makedepends=""
+install="$pkgname.post-install"
+subpackages="$pkgname-doc"
+options="!check" # Just a udev rule and a python script
+source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
+ python3.patch
+ rules-warning.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 xbacklight \
+ "$pkgdir/usr/bin/xbacklight"
+ install -Dm644 90-backlight.rules \
+ "$pkgdir/lib/udev/rules.d/90-$pkgname.rules"
+ install -Dm644 xbacklight.1 \
+ "$pkgdir/usr/share/man/man1/xbacklight.1"
+}
+
+sha512sums="c9b5805f919172d4806942ba1987d0c11fda420a807c45c404eda83cbcfc6011729b09d7ae3113106e006d2ed65ab26e4932869305e48d9493514b597c6e9713 acpilight-1.0.1.tar.gz
+9ed3bc124a0120d7d4ea8831e7bef715c5c45b3e3389aed55261cf436db8cb123a8bffe463a29107cb27161a59ed6a31623e23f2b55797c99be92a2d26eabca0 python3.patch
+63521df95b943c941c6687960b69f4ca51f2b36c3d390ef50738034f13afbab175b0a69c7874bc47bc85a1b8d877a26427eba3a264803b700ff652c3c28cd2ad rules-warning.patch"