summaryrefslogtreecommitdiff
path: root/user/alsa-lib
diff options
context:
space:
mode:
Diffstat (limited to 'user/alsa-lib')
-rw-r--r--user/alsa-lib/APKBUILD20
-rw-r--r--user/alsa-lib/remove-test.patch12
-rw-r--r--user/alsa-lib/type_compat.patch23
3 files changed, 40 insertions, 15 deletions
diff --git a/user/alsa-lib/APKBUILD b/user/alsa-lib/APKBUILD
index 94add5098..49f14066e 100644
--- a/user/alsa-lib/APKBUILD
+++ b/user/alsa-lib/APKBUILD
@@ -1,23 +1,20 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=alsa-lib
-pkgver=1.1.9
+pkgver=1.2.2
pkgrel=0
pkgdesc="Linux sound support system"
url="https://www.alsa-project.org/wiki/Main_Page"
arch="all"
license="LGPL-2.0+"
-subpackages="$pkgname-dev $pkgname-dbg"
+depends=""
makedepends="linux-headers"
+subpackages="$pkgname-dev $pkgname-dbg"
source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2
ucm_add_limits_h.patch
remove-test.patch
+ type_compat.patch
"
-prepare() {
- rm src/compat/hsearch_r.c && touch src/compat/hsearch_r.c
- default_prepare
-}
-
build() {
./configure \
--build=$CBUILD \
@@ -31,6 +28,10 @@ build() {
--enable-aload \
--disable-dependency-tracking \
--without-versioned
+ rm -rf "$builddir"/include/sound
+ mkdir "$builddir"/include/sound
+ printf "all:\ncheck:\ninstall:\n" > "$builddir"/include/sound/Makefile
+
make
}
@@ -42,6 +43,7 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="402e39cca82d17555e3e52ef06b8ed9dcf58531da393809a7b5cf18658299fa90ee8a60bfc5213482d7a02b13140c441f1333b144556f44ab4adb786a2fb3c49 alsa-lib-1.1.9.tar.bz2
+sha512sums="d21adb3ff998918c7d1820f9ce2aaf4202dd45ccb87cb092d49da8b2402b6ddaad06325be0fd59f17393a5d9958e3743bfccb4b14bdb947a42e7d791d73c7033 alsa-lib-1.2.2.tar.bz2
3b37652d50809443b5f8e80f8d447108195b0cd66fd917805bb393fc091584b6f3dad4414f568742b61745617e7a695862058a0a0f93dcc31e4c97177a520352 ucm_add_limits_h.patch
-388443e7d9c90339b273a40205c5cbb14033ec16d357b52b0eaeb97e2f074fab100439f8cb2972011ac1580712448a4861ab2dec26653b55badf1caaaf207a59 remove-test.patch"
+0ce3c2b8a0a70e2dffb6d633b95c4aae74504cd694fe1507cbc409d931b5f733935b22de45e4adcf5a507587c9f80c60a6f0e798aac2ca2fbf0cbcdef0080079 remove-test.patch
+bdcfa3d5fcc055fb6732922679e21689fc2ac19462fe7b72d16862c98ef8c995c3dd5becc4987ba417068e6b0e561bec7e6284d5f0a414e2966c8e00ac304fa8 type_compat.patch"
diff --git a/user/alsa-lib/remove-test.patch b/user/alsa-lib/remove-test.patch
index ba0d78498..92059b0f2 100644
--- a/user/alsa-lib/remove-test.patch
+++ b/user/alsa-lib/remove-test.patch
@@ -19,7 +19,7 @@
client_event_filter_LDADD=../src/libasound.la
--- alsa-lib-1.1.4.1/test/Makefile.in.old 2017-06-01 01:28:25.000000000 -0500
+++ alsa-lib-1.1.4.1/test/Makefile.in 2017-09-27 00:58:29.668332253 -0500
-@@ -52,7 +52,7 @@
+@@ -90,7 +90,7 @@
check_PROGRAMS = control$(EXEEXT) pcm$(EXEEXT) pcm_min$(EXEEXT) \
latency$(EXEEXT) seq$(EXEEXT) playmidi1$(EXEEXT) \
timer$(EXEEXT) rawmidi$(EXEEXT) midiloop$(EXEEXT) \
@@ -28,7 +28,7 @@
client_event_filter$(EXEEXT) chmap$(EXEEXT) \
audio_time$(EXEEXT) user-ctl-element-set$(EXEEXT) \
pcm-multi-thread$(EXEEXT)
-@@ -96,9 +96,6 @@
+@@ -136,9 +136,6 @@
namehint_SOURCES = namehint.c
namehint_OBJECTS = namehint.$(OBJEXT)
namehint_DEPENDENCIES = ../src/libasound.la
@@ -38,7 +38,7 @@
pcm_SOURCES = pcm.c
pcm_OBJECTS = pcm.$(OBJEXT)
pcm_DEPENDENCIES = ../src/libasound.la
-@@ -173,11 +170,11 @@
+@@ -223,11 +219,11 @@
am__v_CCLD_0 = @echo " CCLD " $@;
am__v_CCLD_1 =
SOURCES = audio_time.c chmap.c client_event_filter.c control.c \
@@ -52,7 +52,7 @@
pcm-multi-thread.c pcm_min.c playmidi1.c queue_timer.c \
rawmidi.c seq.c timer.c user-ctl-element-set.c
RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
-@@ -366,7 +363,6 @@
+@@ -439,7 +436,6 @@
timer_LDADD = ../src/libasound.la
rawmidi_LDADD = ../src/libasound.la
midiloop_LDADD = ../src/libasound.la
@@ -60,7 +60,7 @@
queue_timer_LDADD = ../src/libasound.la
namehint_LDADD = ../src/libasound.la
client_event_filter_LDADD = ../src/libasound.la
-@@ -444,9 +440,6 @@
+@@ -524,9 +520,6 @@
@rm -f namehint$(EXEEXT)
$(AM_V_CCLD)$(LINK) $(namehint_OBJECTS) $(namehint_LDADD) $(LIBS)
@@ -70,7 +70,7 @@
pcm$(EXEEXT): $(pcm_OBJECTS) $(pcm_DEPENDENCIES) $(EXTRA_pcm_DEPENDENCIES)
@rm -f pcm$(EXEEXT)
-@@ -488,7 +481,6 @@
+@@ -577,7 +570,6 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/latency.Po@am__quote@ # am--include-marker
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/midiloop.Po@am__quote@ # am--include-marker
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/namehint.Po@am__quote@ # am--include-marker
diff --git a/user/alsa-lib/type_compat.patch b/user/alsa-lib/type_compat.patch
new file mode 100644
index 000000000..4236d11d4
--- /dev/null
+++ b/user/alsa-lib/type_compat.patch
@@ -0,0 +1,23 @@
+Since we force the use of the uapi headers from linux-headers instead of
+using the vendored copy, type_compat.h never gets put in the place it
+should be for it to be seen in sound/.
+
+However, the only reason it was included here anyway was to replace a
+definition that was never used:
+
+https://github.com/alsa-project/alsa-lib/commit/ae564665ec261cf104de499b1cdda3564070fc65#diff-5e0b4d8ecf374a31036ffc7b224d5e7fL21
+
+ -#define __packed __attribute__((__packed__))
+ -
+ +#include <sound/type_compat.h>
+
+--- alsa-lib-1.2.2/src/topology/tplg_local.h 2020-02-19 03:35:39.000000000 -0600
++++ alsa-lib-1.2.2/src/topology/tplg_local.h 2020-03-17 01:26:25.159548858 -0500
+@@ -18,7 +18,6 @@
+ #include "list.h"
+ #include "topology.h"
+
+-#include <sound/type_compat.h>
+ #include <sound/asound.h>
+ #include <sound/asoc.h>
+ #include <sound/tlv.h>