summaryrefslogtreecommitdiff
path: root/user/attica/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/attica/APKBUILD')
-rw-r--r--user/attica/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/attica/APKBUILD b/user/attica/APKBUILD
new file mode 100644
index 000000000..71e980b96
--- /dev/null
+++ b/user/attica/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=attica
+pkgver=5.38.0
+pkgrel=0
+pkgdesc="Qt 5-based implementation of Open Collaboration Services"
+url="https://www.kde.org/"
+arch="all"
+license="LGPL-2.1"
+depends=""
+depends_dev="qt5-qtbase-dev"
+makedepends="$depends_dev cmake extra-cmake-modules"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.kde.org/stable/frameworks/5.38/attica-$pkgver.tar.xz"
+builddir="$srcdir/attica-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="acd69c9e9955062ebd362ab6d2e247e3b37a12f9d470197426f90798b422c64f198a93754d408be72b0e442b97b161218349a71761f6156c87c1feae6f62b2f6 attica-5.38.0.tar.xz"