summaryrefslogtreecommitdiff
path: root/user/attica/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/attica/APKBUILD')
-rw-r--r--user/attica/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/user/attica/APKBUILD b/user/attica/APKBUILD
index 71e980b96..e0453877e 100644
--- a/user/attica/APKBUILD
+++ b/user/attica/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=attica
-pkgver=5.38.0
+pkgver=5.41.0
pkgrel=0
pkgdesc="Qt 5-based implementation of Open Collaboration Services"
url="https://www.kde.org/"
@@ -9,10 +9,11 @@ arch="all"
license="LGPL-2.1"
depends=""
depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev cmake extra-cmake-modules"
+makedepends="$depends_dev cmake extra-cmake-modules doxygen graphviz
+ qt5-qttools-dev"
install=""
-subpackages="$pkgname-dev"
-source="http://download.kde.org/stable/frameworks/5.38/attica-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/attica-$pkgver.tar.xz"
builddir="$srcdir/attica-$pkgver"
build() {
@@ -27,6 +28,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_QCH:BOOL=ON \
${CMAKE_CROSSOPTS}
make
}
@@ -41,4 +43,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="acd69c9e9955062ebd362ab6d2e247e3b37a12f9d470197426f90798b422c64f198a93754d408be72b0e442b97b161218349a71761f6156c87c1feae6f62b2f6 attica-5.38.0.tar.xz"
+sha512sums="9e9fc456bd1e7853140c71fead1ac6205e4f572d1d69d485d95188355e3b2fc775fa85c6d115564bd444f9925526a77da1decf990226ef46302fa5f605d73b09 attica-5.41.0.tar.xz"