summaryrefslogtreecommitdiff
path: root/user/calligra/c99-math.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/calligra/c99-math.patch')
-rw-r--r--user/calligra/c99-math.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/user/calligra/c99-math.patch b/user/calligra/c99-math.patch
new file mode 100644
index 000000000..4326dd7fa
--- /dev/null
+++ b/user/calligra/c99-math.patch
@@ -0,0 +1,18 @@
+--- calligra-3.1.0/filters/words/msword-odf/wv2/CMakeLists.txt.old 2018-01-26 09:24:44.000000000 +0000
++++ calligra-3.1.0/filters/words/msword-odf/wv2/CMakeLists.txt 2018-10-24 23:22:43.440000000 +0000
+@@ -64,12 +64,12 @@
+ set( CMAKE_REQUIRED_INCLUDES math.h )
+ endif()
+
+-check_function_exists( isinf HAVE_FUNC_ISINF )
+-check_function_exists( isnan HAVE_FUNC_ISNAN )
++check_symbol_exists( isinf math.h HAVE_FUNC_ISINF )
++check_symbol_exists( isnan math.h HAVE_FUNC_ISNAN )
+ if(MINGW)
+ add_definitions( -DHAVE_FUNC_ISFINITE )
+ endif()
+-check_function_exists( finite HAVE_FUNC_FINITE )
++check_symbol_exists( finite math.h HAVE_FUNC_FINITE )
+ check_function_exists( _finite HAVE_FUNC__FINITE )
+
+ #