summaryrefslogtreecommitdiff
path: root/user/clazy/fix-link-fs-lib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/clazy/fix-link-fs-lib.patch')
-rw-r--r--user/clazy/fix-link-fs-lib.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/user/clazy/fix-link-fs-lib.patch b/user/clazy/fix-link-fs-lib.patch
new file mode 100644
index 000000000..9096ec57b
--- /dev/null
+++ b/user/clazy/fix-link-fs-lib.patch
@@ -0,0 +1,11 @@
+diff -ur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2022-08-19 00:58:47.518958902 +0000
++++ b/CMakeLists.txt 2022-08-19 01:03:37.193667800 +0000
+@@ -264,6 +264,7 @@
+ target_link_libraries(clazy-standalone clangFrontend)
+ else()
+ target_link_libraries(clazy-standalone ClazyPlugin)
++ target_link_libraries(clazy-standalone stdc++fs)
+ endif()
+
+ link_to_llvm(clazy-standalone TRUE)