summaryrefslogtreecommitdiff
path: root/user/clucene/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/clucene/APKBUILD')
-rw-r--r--user/clucene/APKBUILD5
1 files changed, 0 insertions, 5 deletions
diff --git a/user/clucene/APKBUILD b/user/clucene/APKBUILD
index 2c5e047e4..c76e42c3c 100644
--- a/user/clucene/APKBUILD
+++ b/user/clucene/APKBUILD
@@ -21,14 +21,12 @@ builddir="$srcdir/$pkgname-core-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
# Do not use bundled zlib or boost
sed -ie '/ADD_SUBDIRECTORY (src\/ext)/d' CMakeLists.txt
rm -rf src/ext
}
build() {
- cd "$builddir"
cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_CONTRIBS_LIB=BOOL:ON \
@@ -39,8 +37,6 @@ build() {
}
check() {
- cd "$builddir"
-
# clucene is not smart enough to delete files between successive checks,
# so let's remove them for it. Otherwise, if check is run a second time
# without clearing the files beforehand, a lot of tests will fail.
@@ -56,7 +52,6 @@ check() {
}
package() {
- cd "$builddir"
make install/fast DESTDIR="$pkgdir"
rm -r "$pkgdir"/usr/lib/CLuceneConfig.cmake
}