summaryrefslogtreecommitdiff
path: root/user/cogl
diff options
context:
space:
mode:
Diffstat (limited to 'user/cogl')
-rw-r--r--user/cogl/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/user/cogl/APKBUILD b/user/cogl/APKBUILD
index 900be988e..988e85e8f 100644
--- a/user/cogl/APKBUILD
+++ b/user/cogl/APKBUILD
@@ -6,15 +6,15 @@ pkgrel=0
pkgdesc="GObject-based GL/GLES abstraction library"
url="https://gnome.org"
arch="all"
-options="!check" # broken testsuite, no logs/messages to determine why
+options="!check" # broken testsuite, no logs/messages to determine why
license="MIT AND SGI-B-2.0 AND BSD-3-Clause AND Public-Domain AND LGPL-2.0+ AND Apache-2.0"
+depends=""
makedepends="glib-dev libxcomposite-dev libxrandr-dev mesa-dev cairo-dev
pango-dev vala gobject-introspection-dev gdk-pixbuf-dev"
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.gnome.org/sources/cogl/1.22/cogl-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}