summaryrefslogtreecommitdiff
path: root/user/cppunit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/cppunit/APKBUILD')
-rw-r--r--user/cppunit/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/cppunit/APKBUILD b/user/cppunit/APKBUILD
new file mode 100644
index 000000000..f334d23f1
--- /dev/null
+++ b/user/cppunit/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=cppunit
+pkgver=1.14.0
+pkgrel=0
+pkgdesc="C++ unit testing framework"
+url="https://www.freedesktop.org/wiki/Software/cppunit/"
+arch="all"
+license="LGPL-2.1+"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://dev-www.libreoffice.org/src/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ LIBS="-ldl" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4ea1da423c6f7ab37e4144689f593396829ce74d43872d6b10709c1ad5fbda4ee945842f7e9803592520ef81ac713e95a3fe130295bf048cd32a605d1959882e cppunit-1.14.0.tar.gz"