summaryrefslogtreecommitdiff
path: root/user/cram/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/cram/APKBUILD')
-rw-r--r--user/cram/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/user/cram/APKBUILD b/user/cram/APKBUILD
index 73bb7c8cc..505e64ef8 100644
--- a/user/cram/APKBUILD
+++ b/user/cram/APKBUILD
@@ -8,26 +8,23 @@ url="https://bitheap.org/cram/"
arch="noarch"
license="GPL-2.0-only"
depends="python3"
-makedepends="cmd:which"
checkdepends="coverage"
+makedepends="cmd:which"
subpackages=""
source="https://bitheap.org/cram/cram-$pkgver.tar.gz
die-py2-die.patch
"
build() {
- cd "$builddir"
make PYTHON=python3
}
check() {
- cd "$builddir"
# tests are not 100% coverage
make PYTHON=python3 check || true
}
package() {
- cd "$builddir"
# we can't use make because there's no --root option
python3 setup.py install --prefix=/usr --root="$pkgdir"
}