summaryrefslogtreecommitdiff
path: root/user/dolphin
diff options
context:
space:
mode:
Diffstat (limited to 'user/dolphin')
-rw-r--r--user/dolphin/APKBUILD9
-rw-r--r--user/dolphin/frameworks.patch11
2 files changed, 17 insertions, 3 deletions
diff --git a/user/dolphin/APKBUILD b/user/dolphin/APKBUILD
index 2a7ec1437..1ef7a8908 100644
--- a/user/dolphin/APKBUILD
+++ b/user/dolphin/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=dolphin
-pkgver=18.12.3
+pkgver=19.04.0
pkgrel=0
pkgdesc="Lightweight desktop file manager"
url="https://www.kde.org/applications/system/dolphin/"
@@ -16,7 +16,9 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev kdoctools-dev kinit-dev
baloo-dev kfilemetadata-dev kdelibs4support-dev kactivities-dev
baloo-widgets-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/dolphin-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/dolphin-$pkgver.tar.xz
+ frameworks.patch
+ "
build() {
cd "$builddir"
@@ -44,4 +46,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="369592af52053550eb482fecfbb54fda3d65db75b0bcf000f88c32d4e709e056f8f5399427674b3aac0bcea438fe8fa24bdbb08109373e0c44e495d9c772da1f dolphin-18.12.3.tar.xz"
+sha512sums="6a70c2f4cb76c6d088aeb9e74963cf9da514cf66abc2f8607ea9f191888f0f0b2440c3f4e9585028a45a07b5334ed40f555d85ea0e22e31e42bd0e655e2420d7 dolphin-19.04.0.tar.xz
+4ec4b440f5ed52439152fb6132448e674f8e357413ef1eae339cfefb602a82909bceba85f5f517b51a985e3101d6be42b25bee6a4dd338a190d995deef57c708 frameworks.patch"
diff --git a/user/dolphin/frameworks.patch b/user/dolphin/frameworks.patch
new file mode 100644
index 000000000..3fc7130bb
--- /dev/null
+++ b/user/dolphin/frameworks.patch
@@ -0,0 +1,11 @@
+--- dolphin-19.04.0/CMakeLists.txt.old 2019-04-12 00:02:11.000000000 +0000
++++ dolphin-19.04.0/CMakeLists.txt 2019-04-18 20:17:53.396872289 +0000
+@@ -8,7 +8,7 @@
+ project(Dolphin VERSION ${KDE_APPLICATIONS_VERSION})
+
+ set(QT_MIN_VERSION "5.8.0")
+-set(KF5_MIN_VERSION "5.56.0")
++set(KF5_MIN_VERSION "5.54.0")
+
+ # ECM setup
+ find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)