summaryrefslogtreecommitdiff
path: root/user/dosbox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/dosbox/APKBUILD')
-rw-r--r--user/dosbox/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/dosbox/APKBUILD b/user/dosbox/APKBUILD
new file mode 100644
index 000000000..f346f79fb
--- /dev/null
+++ b/user/dosbox/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Horst Burkhardt <horst@adelielinux.org>
+# Maintainer: Horst Burkhardt <horst@adelielinux.org>
+pkgname=dosbox
+pkgver=0.82.7
+pkgrel=0
+pkgdesc="an emulator for MS-DOS games"
+url="https://github.com/joncampbell123/dosbox-x/"
+arch="all !s390x"
+options="!check" # dosbox does not ship tests
+subpackages=""
+license="GPL-2.0-only"
+depends=""
+makedepends="ncurses-dev zlib-dev libxkbfile-dev libpng-dev libpcap-dev fluidsynth-dev sdl2-dev alsa-lib-dev"
+source="https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-wip-20180513-1316.tar.gz
+ porttalk-fix.patch
+ asmfix.patch
+ "
+builddir="$srcdir/dosbox-x-dosbox-x-wip-20180513-1316"
+
+build() {
+ cd "$builddir"
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-debug --enable-core-inline --enable-sdl2
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="38b7423b695f3b0dfd26f8c8913f26afba73ea6235bb205ec3a5d7f08ef3c74a9b6ce2577f0ea8eb49724b548e3386332256d13f27469b165986702650638992 dosbox-x-wip-20180513-1316.tar.gz
+daf0efea03d6295f5a20d8d197f7d0ba38e0608edcfe8be19fc6091b783885d523557674f0f7df83b88186b77794723106cf7a0e02125d2cc75ecfd7d51fa91d porttalk-fix.patch
+266ede57d21030f7752287f18660b47e9185a9aef9d022337dded9c9ce93e572691b41aca878f8a28c67bf5d217c7e84912336c21aacf594085dc31d99862ebf asmfix.patch" \ No newline at end of file