summaryrefslogtreecommitdiff
path: root/user/firefox-esr/rust-32bit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/firefox-esr/rust-32bit.patch')
-rw-r--r--user/firefox-esr/rust-32bit.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/user/firefox-esr/rust-32bit.patch b/user/firefox-esr/rust-32bit.patch
new file mode 100644
index 000000000..f9281cb7a
--- /dev/null
+++ b/user/firefox-esr/rust-32bit.patch
@@ -0,0 +1,20 @@
+--- firefox-68.1.0/config/makefiles/rust.mk.old 2019-08-26 16:52:20.000000000 +0000
++++ firefox-68.1.0/config/makefiles/rust.mk 2019-10-03 21:17:55.062373830 +0000
+@@ -47,7 +47,7 @@
+ ifndef DEVELOPER_OPTIONS
+ ifndef MOZ_DEBUG_RUST
+ # Enable link-time optimization for release builds.
+-cargo_rustc_flags += -C lto
++# OOMs on 32-bit machines: cargo_rustc_flags += -C lto
+ endif
+ endif
+
+@@ -246,7 +246,7 @@
+ ifndef DEVELOPER_OPTIONS
+ ifndef MOZ_DEBUG_RUST
+ ifeq ($(OS_ARCH), Linux)
+- $(call py_action,check_binary,--target --networking $@)
++# Fails because we disable LTO: $(call py_action,check_binary,--target --networking $@)
+ endif
+ endif
+ endif