summaryrefslogtreecommitdiff
path: root/user/fish/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/fish/APKBUILD')
-rw-r--r--user/fish/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/user/fish/APKBUILD b/user/fish/APKBUILD
index 91c779505..500bf14f9 100644
--- a/user/fish/APKBUILD
+++ b/user/fish/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=fish
-pkgver=3.1.2
+pkgver=3.4.1
pkgrel=0
pkgdesc="Modern interactive commandline shell"
url="http://www.fishshell.com"
@@ -9,11 +9,11 @@ arch="all"
license="BSD-3-Clause AND BSD-2-Clause AND GPL-2.0+ AND GPL-2.0-only AND ISC"
depends="bc groff"
depends_dev="$pkgname-tools"
-checkdepends="expect"
+checkdepends="py3-pexpect"
makedepends="cmake doxygen ncurses-dev pcre2-dev"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools::noarch"
-source="https://github.com/fish-shell/fish-shell/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/fish-shell/fish-shell/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
build() {
cmake \
@@ -54,4 +54,4 @@ tools() {
mv "$pkgdir"/usr/share/$pkgname/tools "$subpkgdir"/usr/share/$pkgname
}
-sha512sums="b6ae2c928774a2eaccf35312d3a9446bfa3e1335182c8f2b2d6198161d0916904f4964fb20ed13a5bf850c1c819e003905d13db3bc8b1faa5b401a60b47dc563 fish-3.1.2.tar.gz"
+sha512sums="20a2892ec0c413c4c3fcfe5fbf52fb2398de35a9172758728bd2ccdccc5fb6e0e18712a664d02db67543d47180a4d04f3998a6297d23088926b6d03baefdf981 fish-3.4.1.tar.xz"