summaryrefslogtreecommitdiff
path: root/user/font-bitstream-75dpi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/font-bitstream-75dpi/APKBUILD')
-rw-r--r--user/font-bitstream-75dpi/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/font-bitstream-75dpi/APKBUILD b/user/font-bitstream-75dpi/APKBUILD
new file mode 100644
index 000000000..a456b9bd6
--- /dev/null
+++ b/user/font-bitstream-75dpi/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=font-bitstream-75dpi
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="75dpi X11 fonts from Bitstream"
+url="https://www.X.Org/"
+arch="noarch"
+license="MIT"
+depends="encodings font-alias fontconfig mkfontdir"
+makedepends="bdftopcf font-util-dev util-macros"
+subpackages=""
+source="https://www.x.org/releases/individual/font/font-bitstream-75dpi-$pkgver.tar.bz2"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" -name fonts.dir -exec rm {} +
+}
+
+sha512sums="9311a5b0cbe1613aca87fdf7fd9ab263eb1129e3c3eacbce54547f2185e151fb1237128b1b6d39f716f28694a486909564ecc9a0aef061438622d11b5661d650 font-bitstream-75dpi-1.0.3.tar.bz2"