summaryrefslogtreecommitdiff
path: root/user/fontconfig
diff options
context:
space:
mode:
Diffstat (limited to 'user/fontconfig')
-rw-r--r--user/fontconfig/APKBUILD45
-rw-r--r--user/fontconfig/fontconfig.trigger4
2 files changed, 49 insertions, 0 deletions
diff --git a/user/fontconfig/APKBUILD b/user/fontconfig/APKBUILD
new file mode 100644
index 000000000..45b62a8ca
--- /dev/null
+++ b/user/fontconfig/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer:
+pkgname=fontconfig
+pkgver=2.13.0
+pkgrel=0
+pkgdesc="Library for configuring and customizing font access"
+url="https://www.freedesktop.org/wiki/Software/fontconfig/"
+arch="all"
+options="!check" # Fails test with fixed fonts
+license="MIT"
+depends=""
+makedepends="freetype-dev expat-dev python3-dev gperf util-linux-dev"
+triggers="$pkgname.trigger=/usr/share/fonts/*"
+subpackages="$pkgname-doc $pkgname-dev"
+source="https://www.freedesktop.org/software/fontconfig/release/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "$builddir"
+ # regenerate hash functions
+ rm -f src/fcobjshash.h
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-static \
+ --disable-docs
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+
+ install -m644 -D COPYING "$pkgdir"/usr/share/licenses/"${pkgname}"/COPYING
+}
+
+sha512sums="5c0f98d1ac8e2ce0b2b59e75a86123967873e71ca3dd0d97911d6e6845a3cb2e099093a92933f55fe5a1c61821de26c1fa07141319c563c6280226b2cdea08e2 fontconfig-2.13.0.tar.gz"
diff --git a/user/fontconfig/fontconfig.trigger b/user/fontconfig/fontconfig.trigger
new file mode 100644
index 000000000..a5512acee
--- /dev/null
+++ b/user/fontconfig/fontconfig.trigger
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+fc-cache --system-only > /dev/null
+