summaryrefslogtreecommitdiff
path: root/user/frameworkintegration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/frameworkintegration/APKBUILD')
-rw-r--r--user/frameworkintegration/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/user/frameworkintegration/APKBUILD b/user/frameworkintegration/APKBUILD
index abaeb67b4..74c234c7c 100644
--- a/user/frameworkintegration/APKBUILD
+++ b/user/frameworkintegration/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=frameworkintegration
-pkgver=5.54.0
+pkgver=5.65.0
pkgrel=0
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
url="https://www.kde.org/"
@@ -17,7 +17,6 @@ subpackages="$pkgname-dev"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -28,18 +27,16 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="9bb0c8a10b342976c21f8840e04f4b9ac60931c804fc0debbddf24b710e97804a2b8d357019840534c4fb4b4b816565a49682b0b09b4fb4d82d7d3467af1bb1f frameworkintegration-5.54.0.tar.xz"
+sha512sums="0af9b631e40d44c06661fd671898f102930f2efec9273f9efc1f7b11a16a42e25525e1a5a9c165e9d901cff01b08f36c1ac9845f316368b7f630a06dd32f414e frameworkintegration-5.65.0.tar.xz"