summaryrefslogtreecommitdiff
path: root/user/frei0r-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'user/frei0r-plugins')
-rw-r--r--user/frei0r-plugins/APKBUILD11
-rw-r--r--user/frei0r-plugins/facebl0r-opencv-3.4.3.patch22
2 files changed, 29 insertions, 4 deletions
diff --git a/user/frei0r-plugins/APKBUILD b/user/frei0r-plugins/APKBUILD
index b959deae1..bbfd1c2ca 100644
--- a/user/frei0r-plugins/APKBUILD
+++ b/user/frei0r-plugins/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=frei0r-plugins
-pkgver=1.5.0
-pkgrel=2
+pkgver=1.6.1
+pkgrel=0
pkgdesc="A minimalistic plugin API for video sources and filters"
url=" "
arch="all"
@@ -12,7 +12,9 @@ depends=""
makedepends="opencv-dev gavl-dev file cairo-dev doxygen
automake autoconf libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://files.dyne.org/frei0r/releases/frei0r-plugins-$pkgver.tar.gz"
+source="https://files.dyne.org/frei0r/releases/frei0r-plugins-$pkgver.tar.gz
+ facebl0r-opencv-3.4.3.patch
+ "
prepare() {
default_prepare
@@ -35,4 +37,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="9be0384421ff5ac9000dcda9acefb5cb2b6dc05ea72d9771fae990cb5fad4424dcef8dd15c1e5031a89169f914af8c7a30e47934ad007a3bc0150f3c005bc6bf frei0r-plugins-1.5.0.tar.gz"
+sha512sums="843790389e6de83817d1c3744a91d3365864bb0c22cf6598707ccba5ec8933f6209434011cde1303e16edd89f6cde2f22aa1fb6eca3548d892a2c77332c44aac frei0r-plugins-1.6.1.tar.gz
+785ff3459f371620780f274b82702c8f6625d78fcd6000fddca0585e3aeaa0af57fd9d9444c4d0f1ca47e84b47b8a2fca4b86fa44ebe93487948eb8f4a193503 facebl0r-opencv-3.4.3.patch"
diff --git a/user/frei0r-plugins/facebl0r-opencv-3.4.3.patch b/user/frei0r-plugins/facebl0r-opencv-3.4.3.patch
new file mode 100644
index 000000000..f3d4f46bb
--- /dev/null
+++ b/user/frei0r-plugins/facebl0r-opencv-3.4.3.patch
@@ -0,0 +1,22 @@
+From b0a06d52e39438fae2afbf98bafe6c794d13b83e Mon Sep 17 00:00:00 2001
+From: Christoph Willing <chris.willing@linux.com>
+Date: Sat, 14 Jul 2018 21:34:03 +1000
+Subject: [PATCH] Include opencv2/imgproc.hpp for CV_RGB()
+
+Signed-off-by: Christoph Willing <chris.willing@linux.com>
+---
+ src/filter/facebl0r/facebl0r.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/filter/facebl0r/facebl0r.cpp b/src/filter/facebl0r/facebl0r.cpp
+index 6d6e8f2..823462a 100644
+--- a/src/filter/facebl0r/facebl0r.cpp
++++ b/src/filter/facebl0r/facebl0r.cpp
+@@ -19,6 +19,7 @@
+ #include <stdlib.h>
+ #include <opencv/cv.h>
+ #include <opencv/highgui.h>
++#include <opencv2/imgproc.hpp>
+
+ #include <frei0r.hpp>
+ #include <frei0r_math.h>