summaryrefslogtreecommitdiff
path: root/user/gambit-c/fix-incompatible-stat-usage.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/gambit-c/fix-incompatible-stat-usage.patch')
-rw-r--r--user/gambit-c/fix-incompatible-stat-usage.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/user/gambit-c/fix-incompatible-stat-usage.patch b/user/gambit-c/fix-incompatible-stat-usage.patch
new file mode 100644
index 000000000..ed046a88c
--- /dev/null
+++ b/user/gambit-c/fix-incompatible-stat-usage.patch
@@ -0,0 +1,21 @@
+Illegal option 's'.
+
+diff -ur a/doc/makefile.in b/doc/makefile.in
+--- a/doc/makefile.in 2022-12-01 12:16:24.110528979 -0600
++++ b/doc/makefile.in 2022-12-01 12:41:45.384526329 -0600
+@@ -129,14 +129,7 @@
+ version.txi: stamp.vti
+
+ stamp.vti: gambit.txi $(rootfromhere)/configure.ac
+- # we need this mess because "date" and "stat"
+- # don't behave the same on Linux and BSD
+- st_mtime="`stat -s gambit.txi | sed -e 's/.*st_mtime=//g' -e 's/ .*//g'`"; \
+- if [ "$$st_mtime" = "" ]; then \
+- mtime="`date -r gambit.txi '+%B %d, %Y'`"; \
+- else \
+- mtime="`date -r $$st_mtime '+%B %d, %Y'`"; \
+- fi; \
++ mtime="`date -r gambit.txi '+%B %d, %Y'`";
+ echo "@set EDITION $(PACKAGE_VERSION)" > version.tmp; \
+ echo "@set UPDATED $$mtime" >> version.tmp; \
+ echo "@set VERSION $(PACKAGE_VERSION)" >> version.tmp