summaryrefslogtreecommitdiff
path: root/user/gnucobol/tests-are-fatal.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/gnucobol/tests-are-fatal.patch')
-rw-r--r--user/gnucobol/tests-are-fatal.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/user/gnucobol/tests-are-fatal.patch b/user/gnucobol/tests-are-fatal.patch
new file mode 100644
index 000000000..933c1128d
--- /dev/null
+++ b/user/gnucobol/tests-are-fatal.patch
@@ -0,0 +1,22 @@
+Backport of r3183
+
+--- gnucobol-3.0-rc1/tests/Makefile.am 2018-04-22 19:55:51.000000000 +0000
++++ gnucobol-3.0-rc1/tests/Makefile.am 2019-06-28 16:49:23.740928336 +0000
+@@ -74,7 +74,7 @@
+ check-local: $(TESTSUITE)
+ @echo testing for working diff && diff - "$(TESTSUITE)" < "$(TESTSUITE)" \
+ || (echo "Error: no working 'diff' in PATH" && false)
+- @$(TESTSUITE) $(TESTSUITEFLAGS) || rm -f testsuite.dir/at-job-fifo
++ @$(TESTSUITE) $(TESTSUITEFLAGS) || (rm -f testsuite.dir/at-job-fifo; exit 1)
+ @rm -f testsuite.dir/at-job-fifo
+
+ clean-local:
+@@ -84,7 +84,7 @@
+ @cp $(srcdir)/run_prog_manual.sh.in $@
+
+ checkmanual: $(TESTSUITE_MANUAL) ./run_prog_manual.sh
+- @$(TESTSUITE_MANUAL) $(TESTSUITEFLAGS) || rm -f testsuite_manual.dir/at-job-fifo
++ @$(TESTSUITE_MANUAL) $(TESTSUITEFLAGS) || (rm -f testsuite_manual.dir/at-job-fifo; exit 1)
+ @rm -f testsuite_manual.dir/at-job-fifo
+
+ # targets that are only logical targets instead of files