summaryrefslogtreecommitdiff
path: root/user/guile/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/guile/APKBUILD')
-rw-r--r--user/guile/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/guile/APKBUILD b/user/guile/APKBUILD
new file mode 100644
index 000000000..d670c2353
--- /dev/null
+++ b/user/guile/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer:
+pkgname=guile
+pkgver=2.2.4
+pkgrel=0
+pkgdesc="Portable, embeddable Scheme implementation written in C"
+url="https://www.gnu.org/software/guile/"
+arch="all"
+options="!check !dbg" # Requires actual LC_COLLATE and LC_MONETARY support.
+license="LGPL-3.0+ AND GPL-3.0+"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+makedepends="gmp-dev libtool ncurses-dev texinfo libunistring-dev libffi-dev
+ gc-dev"
+depends=
+depends_dev="guile gc-dev"
+install=
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ 0002-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch
+ "
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-error-on-warning \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/lib/charset.alias
+}
+
+sha512sums="a200b83a02ef23c8256d9bfb14a141bb6dbca01279a0587bfb672060429c49093088e4b765b7ee5c85cd587a1aeed77d9438d300d3e67cdd6cebbb794d88171e guile-2.2.4.tar.gz
+b1c309cc07830ff1741ef88857f8099187b449580e8d57862886abc367ef1accc5a35636d81eee09247f13d3a751cdc8909fdea05368d3d509bd2039ce06d078 0002-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch"