summaryrefslogtreecommitdiff
path: root/user/haveged
diff options
context:
space:
mode:
Diffstat (limited to 'user/haveged')
-rw-r--r--user/haveged/APKBUILD17
-rw-r--r--user/haveged/fix-cpu-cache-size-detection.patch15
2 files changed, 5 insertions, 27 deletions
diff --git a/user/haveged/APKBUILD b/user/haveged/APKBUILD
index 98fd59e1c..489f85cb5 100644
--- a/user/haveged/APKBUILD
+++ b/user/haveged/APKBUILD
@@ -3,22 +3,19 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer:
pkgname=haveged
-pkgver=1.9.4
-pkgrel=1
+pkgver=1.9.8
+pkgrel=0
pkgdesc="Entropy harvesting daemon using CPU timings"
url="http://www.issihosts.com/haveged/"
arch="all"
license="GPL-3.0+"
-subpackages="$pkgname-doc $pkgname-openrc"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-openrc"
makedepends="linux-headers"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jirka-h/haveged/archive/$pkgver.tar.gz
- fix-cpu-cache-size-detection.patch
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirka-h/haveged/archive/v$pkgver.tar.gz
haveged.initd
haveged.confd"
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,13 +25,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/lib/libhavege.la
@@ -45,7 +39,6 @@ package() {
"$pkgdir"/etc/conf.d/haveged
}
-sha512sums="20017c7637779c0cfa414233bb67efb2976f92c08e4eb1b7ea41ccd483dad755629d8e05fb8560a2db811fc2ded7d05fa081ab10c59341cb4c206595a964641d haveged-1.9.4.tar.gz
-6279296b057f19daf25020ac14997268230af4b11510d6e5c4a86989c119d6b081d2501069af198772302d5cce1464514c749033a4928fb95671268825a84ba8 fix-cpu-cache-size-detection.patch
+sha512sums="6a4012c7ab0ad7df77ae61dd3aca072a7aeca942c180d37c8495009fad13a4c9c0e7bf64a3ffce00e50c06679d4b948c3930a960789a06edf074076cf68d37db haveged-1.9.8.tar.gz
5d1e4186580951d4e6e01193e9c8827ceddaf3c2e28a981fc9176cb446bed32b059304796a77d9db6fb761a21f8fd27dd3d31e06a0fb7a5985b4ea94978fcd64 haveged.initd
58fa2c513e26291047b60ea6d6355ad837c1cb07750a2dfb2a5ebf90cc504a4b6ebf3573869410a06cac85d9b634b3df988e8b033921394da8a5abeee574c822 haveged.confd"
diff --git a/user/haveged/fix-cpu-cache-size-detection.patch b/user/haveged/fix-cpu-cache-size-detection.patch
deleted file mode 100644
index 07da2b46d..000000000
--- a/user/haveged/fix-cpu-cache-size-detection.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Some ARM cpus does not report the cache size or say it is -1
-
-diff --git a/src/havegetune.c b/src/havegetune.c
-index f1a99f2..de39c53 100644
---- a/src/havegetune.c
-+++ b/src/havegetune.c
-@@ -795,6 +795,8 @@ static int vfs_configInfoCache(
- ctype = vfs_configFile(pAnchor, path, vfs_configType);
- strcpy(path+plen, "size");
- size = vfs_configFile(pAnchor, path, vfs_configInt);
-+ if (size == -1)
-+ size = ctype == 'I' ? GENERIC_ICACHE : GENERIC_DCACHE;
- cfg_cacheAdd(pAnchor, SRC_VFS_INDEX, pArgs[1], level, ctype, size);
- }
- }