summaryrefslogtreecommitdiff
path: root/user/hdparm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/hdparm/APKBUILD')
-rw-r--r--user/hdparm/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/user/hdparm/APKBUILD b/user/hdparm/APKBUILD
index f6e5a8f8e..f1ab5fe96 100644
--- a/user/hdparm/APKBUILD
+++ b/user/hdparm/APKBUILD
@@ -6,11 +6,12 @@ pkgrel=0
pkgdesc="Utility for manipulating IDE device parameters"
url="https://sourceforge.net/projects/hdparm"
arch="all"
+options="!check" # This application has no tests.
license="BSD-2-clause OR GPL-2.0-or-later"
+depends=""
makedepends="linux-headers"
-options="!check" # this application has no tests
subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
prepare() {
default_prepare
@@ -18,13 +19,11 @@ prepare() {
}
build() {
- cd "$builddir"
export CFLAGS="$CFLAGS -D_GNU_SOURCE"
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -D -m755 contrib/idectl "$pkgdir"/sbin
install -D -m755 contrib/ultrabayd "$pkgdir"/sbin