summaryrefslogtreecommitdiff
path: root/user/heirloom-pax/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/heirloom-pax/APKBUILD')
-rw-r--r--user/heirloom-pax/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/user/heirloom-pax/APKBUILD b/user/heirloom-pax/APKBUILD
new file mode 100644
index 000000000..412ed6f8a
--- /dev/null
+++ b/user/heirloom-pax/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=heirloom-pax
+pkgver=1.0
+pkgrel=0
+pkgdesc="Portable Archive eXchange, the POSIX archival tool"
+url="http://heirloom.sourceforge.net/"
+arch="all"
+options="!check" # No test suite.
+license="Zlib"
+replaces="pax"
+makedepends="bsd-compat-headers bzip2-dev zlib-dev"
+subpackages="$pkgname-doc"
+source="https://distfiles.adelielinux.org/source/${pkgname}-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ make LD="gcc"
+}
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/5bin
+ mkdir -p "$pkgdir"/usr/share/man/man1
+ make install ROOT="$pkgdir"
+ rm -r "$pkgdir"/usr/5bin # we don't need 1992 spec pax
+}
+
+sha512sums="7b0ad20cc51b5bcec9c07e84c603e4891f636944f6f6bd13d3decb0e9d6b23d6164b663468ee2293b37721aae20334774f4e56fd8541ffceee934050e819b642 heirloom-pax-1.0.tar.xz"