summaryrefslogtreecommitdiff
path: root/user/htop
diff options
context:
space:
mode:
Diffstat (limited to 'user/htop')
-rw-r--r--user/htop/APKBUILD37
-rw-r--r--user/htop/fix-python-path.patch8
2 files changed, 45 insertions, 0 deletions
diff --git a/user/htop/APKBUILD b/user/htop/APKBUILD
new file mode 100644
index 000000000..2dc87cfa7
--- /dev/null
+++ b/user/htop/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=htop
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="Interactive process viewer"
+url="http://hisham.hm/htop"
+arch="all"
+options="!check" # No test suite.
+license="GPL-2.0+"
+depends=""
+makedepends="ncurses-dev python3"
+subpackages="$pkgname-doc"
+source="http://hisham.hm/htop/releases/$pkgver/$pkgname-$pkgver.tar.gz
+ fix-python-path.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-cgroup \
+ --enable-taskstats
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ec1335bf0e3e0387e5e50acbc508d0effad19c4bc1ac312419dc97b82901f4819600d6f87a91668f39d429536d17304d4b14634426a06bec2ecd09df24adc62e htop-2.2.0.tar.gz
+16358bcd6d83181cc04dd8a7971f7cc0804dc49995208bad2042bcca7962f562bbd008c2185f24aa6186c58896e94e4ec02e2053dc46ed14789889d64836b679 fix-python-path.patch"
diff --git a/user/htop/fix-python-path.patch b/user/htop/fix-python-path.patch
new file mode 100644
index 000000000..4d11bfb4a
--- /dev/null
+++ b/user/htop/fix-python-path.patch
@@ -0,0 +1,8 @@
+--- a/scripts/MakeHeader.py
++++ b/scripts/MakeHeader.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ import os, sys, string, io
+ try:
+ from StringIO import StringIO