summaryrefslogtreecommitdiff
path: root/user/hyfetch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/hyfetch/APKBUILD')
-rw-r--r--user/hyfetch/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/hyfetch/APKBUILD b/user/hyfetch/APKBUILD
new file mode 100644
index 000000000..5bc1e7b01
--- /dev/null
+++ b/user/hyfetch/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Zach van Rijn <me@zv.io>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=hyfetch
+pkgver=1.4.11
+pkgrel=0
+pkgdesc="Neofetch with LGBTQ+ pride flags!"
+url="https://github.com/hykilpikonna/hyfetch"
+arch="noarch"
+options="!check" # no test suite
+license="MIT"
+depends="bash python3"
+makedepends="make python3"
+provides="neofetch"
+replaces="neofetch"
+subpackages="$pkgname-doc"
+source="neofetch-$pkgver.tar.gz::https://github.com/hykilpikonna/hyfetch/archive/refs/tags/$pkgver.tar.gz
+ python3.patch
+ no-typing-extensions.patch
+ "
+
+build() {
+ # this builds hyfetch; neofetch does not need to be "built"
+ make
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ make DESTDIR="$pkgdir" install-neofetch install-doc
+}
+
+sha512sums="13c757fed68c9aa1caa503553d6d29c0b68284029090b970b863dec3240dabb28a852ef0ec0f2742c6c268e30a15c48018a651e74ba0e6782b5aa14f2b1d1312 neofetch-1.4.11.tar.gz
+059f8e8293ae82c209e67b059f13e277ce10cc6bf96e6bc1f1459a79f986f733c24ea2b7a5ac1d871432359d5d8154622562de506624be353f8aa7d8561179d7 python3.patch
+4a983329d3bd3165eca86ce8c907945178becba0fd7d4b6381adab64c92938d52225a349325931ff69e7fa87f9c529d6d9758f00170dcbb375ea4e44aeb0e403 no-typing-extensions.patch"