summaryrefslogtreecommitdiff
path: root/user/hyfetch/no-typing-extensions.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/hyfetch/no-typing-extensions.patch')
-rw-r--r--user/hyfetch/no-typing-extensions.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/user/hyfetch/no-typing-extensions.patch b/user/hyfetch/no-typing-extensions.patch
new file mode 100644
index 000000000..196a30dba
--- /dev/null
+++ b/user/hyfetch/no-typing-extensions.patch
@@ -0,0 +1,21 @@
+diff -ur a/hyfetch/types.py b/hyfetch/types.py
+--- a/hyfetch/types.py 2023-12-04 14:12:43.498520221 -0600
++++ b/hyfetch/types.py 2023-12-04 14:14:58.530114564 -0600
+@@ -1,4 +1,4 @@
+-from typing_extensions import Literal
++from typing import Literal
+
+ AnsiMode = Literal['default', 'ansi', '8bit', 'rgb']
+ LightDark = Literal['light', 'dark']
+diff -ur a/setup.py b/setup.py
+--- a/setup.py 2023-12-04 14:12:43.498520221 -0600
++++ b/setup.py 2023-12-04 14:13:04.931087575 -0600
+@@ -37,7 +37,7 @@
+ include_package_data=True,
+ install_requires=[
+ # Universal dependencies
+- 'setuptools', 'typing_extensions',
++ 'setuptools',
+
+ # Windows dependencies
+ 'psutil ; platform_system=="Windows"',