summaryrefslogtreecommitdiff
path: root/user/i3lock/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/i3lock/APKBUILD')
-rw-r--r--user/i3lock/APKBUILD29
1 files changed, 7 insertions, 22 deletions
diff --git a/user/i3lock/APKBUILD b/user/i3lock/APKBUILD
index a84c7b712..098767d75 100644
--- a/user/i3lock/APKBUILD
+++ b/user/i3lock/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=i3lock
-pkgver=2.12
+pkgver=2.15
pkgrel=0
pkgdesc="Simple X11 screen locker"
url="https://i3wm.org/i3lock/"
@@ -9,33 +9,18 @@ arch="all"
options="!check" # No test suite.
license="MIT"
depends="xkeyboard-config"
-makedepends="cairo-dev libev-dev libxkbcommon-dev linux-pam-dev cmd:which
+makedepends="cairo-dev libev-dev libxkbcommon-dev linux-pam-dev meson
xcb-util-image-dev xcb-util-xrm-dev"
subpackages="$pkgname-doc"
-source="$url/$pkgname-$pkgver.tar.bz2"
-
-prepare() {
- default_prepare
- # At present, this has no functional difference.
- # But when we start developing our PAM stack into something more
- # mature, this will be important, because i3lock runs unprivileged.
- sed -i -e 's:login:base-auth:g' pam/i3lock
-}
+source="$url/$pkgname-$pkgver.tar.xz"
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
-
- make
+ meson setup -Dprefix=/usr build
+ meson compile -C build
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
}
-sha512sums="84f1558368381bcad9a64f41ab6134a6614dea453d1ee5ecfe886185b9e1baebeeca446c4635158deb8dae5b25c09d47d3990239d76c44e5325ca5bfaad9b2ad i3lock-2.12.tar.bz2"
+sha512sums="6079f5233c0820c6e38f3cd8f3732d585e95e7d670408e4fb18ab580a2e1face8f3d6ea13eaaeedc8671f74def917183667e736b35306bf7c630d40625b41ac2 i3lock-2.15.tar.xz"