summaryrefslogtreecommitdiff
path: root/user/i3wm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/i3wm/APKBUILD')
-rw-r--r--user/i3wm/APKBUILD31
1 files changed, 14 insertions, 17 deletions
diff --git a/user/i3wm/APKBUILD b/user/i3wm/APKBUILD
index 875d58a01..1f6414355 100644
--- a/user/i3wm/APKBUILD
+++ b/user/i3wm/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=i3wm
-pkgver=4.18.2
+pkgver=4.19.2
pkgrel=0
pkgdesc="Improved dynamic tiling window manager"
url="https://i3wm.org"
@@ -12,36 +12,33 @@ license="BSD-3-Clause"
depends=""
checkdepends="perl-x11-xcb perl-anyevent perl-json-xs perl-ipc-run
perl-inline-c perl-dev libxcb-dev xcb-util-dev xorg-server-xephyr"
-makedepends="bison flex libxcb-dev xcb-util-cursor-dev xcb-util-keysyms-dev
- xcb-util-wm-dev libev-dev pango-dev cairo-dev yajl-dev
- startup-notification-dev pcre-dev libxkbcommon-dev xcb-util-xrm-dev"
+makedepends="meson ninja bison flex libxcb-dev xcb-util-cursor-dev
+ xcb-util-keysyms-dev xcb-util-wm-dev libev-dev pango-dev cairo-dev
+ yajl-dev startup-notification-dev pcre-dev libxkbcommon-dev
+ xcb-util-xrm-dev"
subpackages="$pkgname-doc"
-source="https://i3wm.org/downloads/i3-$pkgver.tar.bz2
+source="https://i3wm.org/downloads/i3-$pkgver.tar.xz
i3wm-musl-glob-tilde.patch
- i3wm-test-fix-off_t.patch
- i3wm-test-disable-branch-check.patch"
+ i3wm-test-fix-off_t.patch"
builddir="$srcdir/i3-$pkgver"
build() {
- ./configure \
- --prefix=/usr \
- --disable-builddir \
- --sysconfdir=/etc
- make
+ # docs require asciidoc
+ meson -Dprefix=/usr -Ddocs=false -Dmans=false build
+ ninja -C build
}
check() {
- make check
+ ninja -C build test
}
package() {
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" ninja -C build install
install -d "$pkgdir/usr/share/man/man1"
install -m644 man/*.1 "$pkgdir"/usr/share/man/man1/
}
-sha512sums="997c7cdf32f95ba25cfcd483a09f7e37e5219e4501baefa5c1865ddffd206bc9725211e4082663fab4174dc947b663ff454d343a7e30340ac3ea451f999417fc i3-4.18.2.tar.bz2
+sha512sums="58f08228d842cd3c2bc417b72f6279fcd7050879e5fd4064b2cb00edaf98b6605d5b2361608f9534991a0f8357d3294e881c7e314f33dc075241cc45ca5ed94d i3-4.19.2.tar.xz
6378e3619076c03345b4faa1f9d54cab2e7173068bc4d5f2f2894af9cc0e5792fe45ce95cb06328f5040f0ba6d43f3e49c523968732ac2d2046b698042338caa i3wm-musl-glob-tilde.patch
-77224b994397b2e2487ae28dfd5781b3630654191813eb3c685f05ebf446e65c36e53a665ff3cc8323ea67e87f7cf977044025dade0a6ed22cbd84f0e6b4cbc7 i3wm-test-fix-off_t.patch
-a80384965dff62c51ce77e2baa3cf1b0b6db1df68994ce98383f96554bd296b4b59527fb5b1cb24b08c123699e294ba9b3baaa52afe88d87e7a76f0629194b1f i3wm-test-disable-branch-check.patch"
+77224b994397b2e2487ae28dfd5781b3630654191813eb3c685f05ebf446e65c36e53a665ff3cc8323ea67e87f7cf977044025dade0a6ed22cbd84f0e6b4cbc7 i3wm-test-fix-off_t.patch"