summaryrefslogtreecommitdiff
path: root/user/iceauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/iceauth/APKBUILD')
-rw-r--r--user/iceauth/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/iceauth/APKBUILD b/user/iceauth/APKBUILD
new file mode 100644
index 000000000..5f59f51ce
--- /dev/null
+++ b/user/iceauth/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer:
+pkgname=iceauth
+pkgver=1.0.8
+pkgrel=0
+pkgdesc="X.Org ICE authority file utility"
+url="http://xorg.freedesktop.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+makedepends="libice-dev util-macros"
+source="http://www.x.org/releases/individual/app/iceauth-$pkgver.tar.bz2"
+
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9d4520adf951b16a3e784349dbb70d5d8176b74b956f8adc63abf55d049745c113b03ccfa60a281fc39b487db3742302dc6287c9985ce83a0157bf4674df2af1 iceauth-1.0.8.tar.bz2"