summaryrefslogtreecommitdiff
path: root/user/iw
diff options
context:
space:
mode:
Diffstat (limited to 'user/iw')
-rw-r--r--user/iw/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/user/iw/APKBUILD b/user/iw/APKBUILD
new file mode 100644
index 000000000..65c762edf
--- /dev/null
+++ b/user/iw/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Luis Ressel <aranea@aixah.de>
+# Maintainer: Luis Ressel <aranea@aixah.de>
+pkgname=iw
+pkgver=5.0.1
+pkgrel=0
+pkgdesc="CLI configuration utility for wireless devices"
+url="https://wireless.wiki.kernel.org/en/users/Documentation/iw"
+arch="all"
+options="!check" # no usable test suite
+license="ISC"
+depends=""
+makedepends="libnl3-dev linux-headers pkgconfig"
+subpackages="$pkgname-doc"
+source="https://kernel.org/pub/software/network/$pkgname/$pkgname-$pkgver.tar.xz"
+
+build() {
+ make V=1
+}
+
+package() {
+ make V=1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="98764c1be7c63f86cc10193319e18c216a3f9a323444723b2949db0738ff8fcff04e6d78c035b5448c083d825a4b4cde27ec607539ec79b1898af73a7969c544 iw-5.0.1.tar.xz"