summaryrefslogtreecommitdiff
path: root/user/kauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/kauth/APKBUILD')
-rw-r--r--user/kauth/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/user/kauth/APKBUILD b/user/kauth/APKBUILD
index 84a0239a1..e517740b3 100644
--- a/user/kauth/APKBUILD
+++ b/user/kauth/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kauth
-pkgver=5.38.0
+pkgver=5.41.0
pkgrel=0
pkgdesc="Framework for allowing software to gain temporary privileges"
url="https://www.kde.org/"
@@ -9,10 +9,10 @@ arch="all"
license="LGPL-2.1"
depends=""
depends_dev="polkit-qt-1-dev qt5-qtbase-dev kcoreaddons-dev"
-makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev"
+makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev doxygen"
install=""
-subpackages="$pkgname-dev $pkgname-lang"
-source="http://download.kde.org/stable/frameworks/5.38/kauth-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
builddir="$srcdir/kauth-$pkgver"
build() {
@@ -27,6 +27,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_QCH:BOOL=ON \
${CMAKE_CROSSOPTS}
make
}
@@ -41,4 +42,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="00b7e1a5e9149ab0a462571f5fcc60594ef0880772ea9bcb3c5e11f4c976c3de0db8b01ce1cae0639e4176a34fde00b0ab9d5b9b25474b3cbc1945098a49220d kauth-5.38.0.tar.xz"
+sha512sums="cbdd40ccd9c0cf067cb08b0db252f4cef1ea58a810246e232038caabadd92111e6b8cd3947f1591cd5e69e5ee00f8b9d93fce6ef0c063cb7991e0d88948d6bd6 kauth-5.41.0.tar.xz"