summaryrefslogtreecommitdiff
path: root/user/kcoreaddons
diff options
context:
space:
mode:
Diffstat (limited to 'user/kcoreaddons')
-rw-r--r--user/kcoreaddons/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/user/kcoreaddons/APKBUILD b/user/kcoreaddons/APKBUILD
index 894a326cb..04875c5b0 100644
--- a/user/kcoreaddons/APKBUILD
+++ b/user/kcoreaddons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kcoreaddons
-pkgver=5.38.0
+pkgver=5.41.0
pkgrel=0
pkgdesc="Core KF5 framework"
url="https://www.kde.org/"
@@ -9,11 +9,11 @@ arch="all"
license="LGPL-2.1"
depends=""
depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev
+makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev doxygen
shared-mime-info"
install=""
-subpackages="$pkgname-dev $pkgname-lang"
-source="http://download.kde.org/stable/frameworks/5.38/kcoreaddons-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/kcoreaddons-$pkgver.tar.xz"
builddir="$srcdir/kcoreaddons-$pkgver"
build() {
@@ -28,6 +28,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_QCH:BOOL=ON \
${CMAKE_CROSSOPTS}
make
}
@@ -42,4 +43,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1f8b339e858c422943836c2c977922b1fef77b562fcc6b8c13e199db1576d06b97fd11fc5286414015a386b2736af3e51fc49cfde346801e2c55aeb9021ce402 kcoreaddons-5.38.0.tar.xz"
+sha512sums="86d6943c303786e4c7b5ea3e2f5c17dae89152597e305316b5e5977e7a037727579a25fd4d6e6f8c272bcae24af5185b06d87189a0a6a8ab8b8232cd059c030f kcoreaddons-5.41.0.tar.xz"