summaryrefslogtreecommitdiff
path: root/user/kcrash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/kcrash/APKBUILD')
-rw-r--r--user/kcrash/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/user/kcrash/APKBUILD b/user/kcrash/APKBUILD
index 3346b13f9..402b7f338 100644
--- a/user/kcrash/APKBUILD
+++ b/user/kcrash/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kcrash
-pkgver=5.38.0
+pkgver=5.41.0
pkgrel=0
pkgdesc="Framework for gracefully handling software errors~"
url="https://www.kde.org/"
@@ -11,11 +11,12 @@ options="!checkroot !check" # Requires running KDE Plasma 5 session
depends=""
depends_dev="qt5-qtbase-dev libx11-dev libxext-dev libice-dev kcoreaddons-dev
kwindowsystem-dev"
-makedepends="$depends_dev cmake extra-cmake-modules"
+makedepends="$depends_dev cmake extra-cmake-modules doxygen graphviz
+ qt5-qttools-dev"
checkdepends="xkeyboard-config"
install=""
-subpackages="$pkgname-dev"
-source="http://download.kde.org/stable/frameworks/5.38/kcrash-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/kcrash-$pkgver.tar.xz"
builddir="$srcdir/kcrash-$pkgver"
build() {
@@ -30,6 +31,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_QCH:BOOL=ON \
${CMAKE_CROSSOPTS}
make
}
@@ -44,4 +46,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="60c13b2e883d3e55b9f431eb1dd7c7332c7e196fe903d0c7fe7f70029ba77600802cc8911be65fb84e1526fb5d9f548d85f6c881e209dee1922aee961279d1b9 kcrash-5.38.0.tar.xz"
+sha512sums="ff21f33d14813aad00a2cc231cb889eb219555ee0302a3575d0ea5e237d7b5d6b9a50c354b289b087ccbce9bd4b5c76e8c94e7bde6a00e8148c63a13e79780ef kcrash-5.41.0.tar.xz"