summaryrefslogtreecommitdiff
path: root/user/kemoticons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/kemoticons/APKBUILD')
-rw-r--r--user/kemoticons/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/user/kemoticons/APKBUILD b/user/kemoticons/APKBUILD
index 560ae3b07..1de6f877e 100644
--- a/user/kemoticons/APKBUILD
+++ b/user/kemoticons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kemoticons
-pkgver=5.54.0
+pkgver=5.65.0
pkgrel=0
pkgdesc="Emoticons to express emotions in KDE"
url="https://www.kde.org/"
@@ -16,7 +16,6 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kemoticons-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -28,18 +27,16 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_QCH:BOOL=ON \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="3b76a6e92cdc0db08179e35c2728f8729c0b1e15d54d17ccec2f265266535f5bf8edc791530d3e65a1ab2b645fd898cb0dba4dade95490f4a73b90c804719886 kemoticons-5.54.0.tar.xz"
+sha512sums="6cc7ae2581c4de3010658ca7941c983737fd68fd7f57405977e7fe5103d715509c3b2a3caa9b29262f6ec1e90c62ddc2e0cc6afdb2b85421c207617c8e5339df kemoticons-5.65.0.tar.xz"