summaryrefslogtreecommitdiff
path: root/user/keyutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/keyutils/APKBUILD')
-rw-r--r--user/keyutils/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/user/keyutils/APKBUILD b/user/keyutils/APKBUILD
new file mode 100644
index 000000000..4696cafef
--- /dev/null
+++ b/user/keyutils/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=keyutils
+pkgver=1.5.10
+pkgrel=1
+pkgdesc="Linux key management utilities"
+url="https://people.redhat.com/~dhowells/keyutils/"
+arch="all"
+options="!check" # Test suite requires RPM.
+license="GPL-2.0+ AND LGPL-2.1+"
+depends=""
+makedepends="file linux-headers"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://people.redhat.com/~dhowells/keyutils/keyutils-$pkgver.tar.bz2
+ fix-includes.patch
+ "
+
+build() {
+ cd "$builddir"
+ make -j1 \
+ NO_ARLIB=1 \
+ LIBDIR=/lib \
+ USRLIBDIR=/usr/lib \
+ VERSION=$pkgver \
+ RELEASE=-r$pkgrel \
+ CFLAGS="$CFLAGS"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" \
+ NO_ARLIB=1 \
+ LIBDIR=/lib \
+ USRLIBDIR=/usr/lib \
+ install
+}
+
+libs() {
+ pkgdesc="Key utilities library"
+ mkdir -p "$subpkgdir"
+ mv "$pkgdir"/lib "$subpkgdir"/
+}
+
+sha512sums="7f6f956c7e76cdc2aeb52e74fe670b20a5f9a5d9b543fd2ce971d80c48745f37d05235a42f0a8f152b1128a109c7d8bf07e751282a20d2d3f433a99a5308ae8d keyutils-1.5.10.tar.bz2
+e7a913c97c4116e5f4b7fdf4d071835dcf05a7aa4ce782fd717e4694414023fb3ed88b8a15710b15869545046e99f706fe8476f9d4fe6578d2eae571e1ed8103 fix-includes.patch"