summaryrefslogtreecommitdiff
path: root/user/kholidays
diff options
context:
space:
mode:
Diffstat (limited to 'user/kholidays')
-rw-r--r--user/kholidays/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/user/kholidays/APKBUILD b/user/kholidays/APKBUILD
index 1f19194a9..35bba4923 100644
--- a/user/kholidays/APKBUILD
+++ b/user/kholidays/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kholidays
-pkgver=5.54.0
+pkgver=5.65.0
pkgrel=0
pkgdesc="List of national holidays for many countries"
url="https://www.kde.org/"
@@ -14,7 +14,6 @@ subpackages="$pkgname-dev $pkgname-lang"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kholidays-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -25,19 +24,17 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
# Requires *actual* *locale* *support*!
CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E testholidayregion
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="709b229c31cb59692d979d8dc36574997e05d674b2cd14913c620a968b243bbcd88f14e9f488f6aec6615102f713c1b4d34f6b817111396cdfedd470d358a675 kholidays-5.54.0.tar.xz"
+sha512sums="b8d45522052a5c48bd9219041d394fabe1f1a3ba29c3ccc649c73f01e40c85b3746f47f083bb1db0242bf2e59f3725ce86cb046cc3e99f56e638e9f990af04f5 kholidays-5.65.0.tar.xz"