summaryrefslogtreecommitdiff
path: root/user/knotifications/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/knotifications/APKBUILD')
-rw-r--r--user/knotifications/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/user/knotifications/APKBUILD b/user/knotifications/APKBUILD
index 39b8a7fbc..9fa972b9c 100644
--- a/user/knotifications/APKBUILD
+++ b/user/knotifications/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=knotifications
-pkgver=5.38.0
-pkgrel=0
+pkgver=5.41.0
+pkgrel=1
pkgdesc="Framework for sending notifications to users"
url="https://www.kde.org/"
arch="all"
@@ -12,10 +12,10 @@ depends=""
depends_dev="qt5-qtbase-dev qt5-qtx11extras-dev kwindowsystem-dev kconfig-dev
kcodecs-dev kcoreaddons-dev phonon-dev libdbusmenu-qt-dev"
makedepends="$depends_dev cmake extra-cmake-modules libx11-dev libxext-dev
- libice-dev qt5-qttools-dev"
+ libice-dev qt5-qttools-dev doxygen graphviz"
install=""
-subpackages="$pkgname-dev $pkgname-lang"
-source="http://download.kde.org/stable/frameworks/5.38/knotifications-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/knotifications-$pkgver.tar.xz"
builddir="$srcdir/knotifications-$pkgver"
build() {
@@ -30,6 +30,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_QCH:BOOL=ON \
${CMAKE_CROSSOPTS}
make
}
@@ -44,4 +45,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="47d3268edd3162f48973e3ca0586df73ec3115b100c866e014e8dbf4b36f5102d85d97d722e849641415e2f91e7e1f2e5976b42e7a34ae95ba8ecf88e8ec0672 knotifications-5.38.0.tar.xz"
+sha512sums="403adbafd6408bfe8c38afd312ec3b2b4f73d6601a6ea076d309ea7e7e599365cd89dbd5aad2358fb931c1414c22069228dd7991f65dc0adbeda54701f70354d knotifications-5.41.0.tar.xz"