summaryrefslogtreecommitdiff
path: root/user/kpeople/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/kpeople/APKBUILD')
-rw-r--r--user/kpeople/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/user/kpeople/APKBUILD b/user/kpeople/APKBUILD
index d6db40186..c0e952933 100644
--- a/user/kpeople/APKBUILD
+++ b/user/kpeople/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kpeople
-pkgver=5.54.0
+pkgver=5.65.0
pkgrel=0
pkgdesc="Provides access to all contacts and groups them by physical person"
url="https://api.kde.org/frameworks/kpeople/html/index.html"
@@ -19,7 +19,6 @@ source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kpeople-$pkgver.
"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -31,19 +30,17 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_QCH:BOOL=ON \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="8f4709cfb256eb7f836d64ee5dcec9962323a8d2d4b362a01fb140af53b7b16db5dd6bd4c8246af67086bee4e2baa9b40e66e877486900c32eb51cb3483a899c kpeople-5.54.0.tar.xz
+sha512sums="013a02fe885b726490560892828f811c2d0134cafc5a8390ad061afebb9eecdb7a41913036729acfae45cd3b98b45b788734f095efa86bca0b71e78497dda3a6 kpeople-5.65.0.tar.xz
77df2aefcdfb8e5b9c2fef7a6bfd79066819b0c6958b9e2f8fe94860155aaae9c284a110a15a189cd5b423dc7aa017b952196370f60a4fb382ed7eb77f15abd9 dont-crash-test.patch"