summaryrefslogtreecommitdiff
path: root/user/kplotting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/kplotting/APKBUILD')
-rw-r--r--user/kplotting/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/user/kplotting/APKBUILD b/user/kplotting/APKBUILD
index 89f78f698..1661cf6f1 100644
--- a/user/kplotting/APKBUILD
+++ b/user/kplotting/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kplotting
-pkgver=5.54.0
+pkgver=5.68.0
pkgrel=0
pkgdesc="Framework for data plotting functions"
url="https://www.kde.org/"
@@ -16,7 +16,6 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kplotting-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -28,18 +27,16 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_QCH:BOOL=ON \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="85cec93bd25a673bcaed993c9130529c1f16e726b3c40f84395f1c2e4810b85503dc3f015ef5cdc1289b793cc19abd956d54a61c2f8e1626ab73b9112107b61d kplotting-5.54.0.tar.xz"
+sha512sums="f4b5158afc2eb4d38278618a475dbc26482682cc77d7ae0e3bb799b25a43f156946791156f73a1fd030b7602fb691364e491bef4686d36bc4f955ac2b8033e1b kplotting-5.68.0.tar.xz"