summaryrefslogtreecommitdiff
path: root/user/kstars
diff options
context:
space:
mode:
Diffstat (limited to 'user/kstars')
-rw-r--r--user/kstars/0001-htmesh-Fix-compile-error-on-modern-Linux-systems.patch25
-rw-r--r--user/kstars/APKBUILD52
2 files changed, 77 insertions, 0 deletions
diff --git a/user/kstars/0001-htmesh-Fix-compile-error-on-modern-Linux-systems.patch b/user/kstars/0001-htmesh-Fix-compile-error-on-modern-Linux-systems.patch
new file mode 100644
index 000000000..052b849d9
--- /dev/null
+++ b/user/kstars/0001-htmesh-Fix-compile-error-on-modern-Linux-systems.patch
@@ -0,0 +1,25 @@
+From b2b36b864813e512829ab8a3613f8a91f2bff20e Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Wed, 29 Aug 2018 11:27:38 -0500
+Subject: [PATCH] htmesh: Fix compile error on modern Linux systems
+
+---
+ kstars/htmesh/SkipListElement.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/kstars/htmesh/SkipListElement.h b/kstars/htmesh/SkipListElement.h
+index f8187e42a..52dfff38a 100644
+--- a/kstars/htmesh/SkipListElement.h
++++ b/kstars/htmesh/SkipListElement.h
+@@ -20,7 +20,7 @@
+ #define KEY_MAX _I64_MAX
+ #else
+ #if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__) || \
+- (defined(__SUNPRO_CC) && defined(__sun)) || defined(__APPLE__)
++ (defined(__SUNPRO_CC) && defined(__sun)) || defined(__APPLE__) || defined(__linux__)
+ #define KEY_MAX LLONG_MAX
+ #else
+ #define KEY_MAX LONG_LONG_MAX
+--
+2.17.1
+
diff --git a/user/kstars/APKBUILD b/user/kstars/APKBUILD
new file mode 100644
index 000000000..11b503db3
--- /dev/null
+++ b/user/kstars/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=kstars
+pkgver=2.9.8
+pkgrel=0
+pkgdesc="Desktop planetarium"
+url="https://www.kde.org/applications/education/kstars/"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev
+ qt5-qtsvg-dev knotifyconfig-dev kauth-dev kconfig-dev kcrash-dev
+ kdoctools-dev kwidgetsaddons-dev knewstuff-dev ki18n-dev kio-dev
+ kxmlgui-dev kplotting-dev knotifications-dev eigen-dev mesa-dev
+ qt5-qtwebsockets-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.kde.org/stable/kstars/kstars-$pkgver.tar.xz
+ 0001-htmesh-Fix-compile-error-on-modern-Linux-systems.patch
+ "
+
+build() {
+ cd "$builddir"
+ mkdir build
+ cd build
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DEIGEN3_INCLUDE_DIR=/usr/include/eigen3 \
+ ${CMAKE_CROSSOPTS} \
+ ..
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="52bc57cd5c46d470f6b49441512708c4446da6cb894cc4f450e8a98616fac8a7d8bcce7ceebcc9a78763f7df612b9cf33498944feed24f2a4104f6b838dc7925 kstars-2.9.8.tar.xz
+8c81a6db810a99b7d8bf7adca15767fdbfb79269ab2de1e4136de3c75266dde2fd572b961f63dc9b4f619abf7292e02eed5d29ca9ba53586f30871aba6015fdb 0001-htmesh-Fix-compile-error-on-modern-Linux-systems.patch"