summaryrefslogtreecommitdiff
path: root/user/libcmis
diff options
context:
space:
mode:
Diffstat (limited to 'user/libcmis')
-rw-r--r--user/libcmis/APKBUILD11
-rw-r--r--user/libcmis/icu.patch17
2 files changed, 24 insertions, 4 deletions
diff --git a/user/libcmis/APKBUILD b/user/libcmis/APKBUILD
index bfc58c4d5..4917aab08 100644
--- a/user/libcmis/APKBUILD
+++ b/user/libcmis/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libcmis
pkgver=0.5.2
-pkgrel=0
+pkgrel=1
pkgdesc="CMIS protocol client library for C/C++"
url="https://github.com/tdf/libcmis"
arch="all"
license="MPL-1.1 OR GPL-2.0+ OR LGPL-2.0+"
depends=""
depends_dev="boost-dev"
-makedepends="$depends_dev curl-dev libxml2-dev"
checkdepends="cppunit-dev"
+makedepends="$depends_dev curl-dev libxml2-dev"
subpackages="$pkgname-dev cmis-client:client"
-source="https://github.com/tdf/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/tdf/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
+ icu.patch
+ "
build() {
# Note: manpages require docbook2x to build
@@ -42,4 +44,5 @@ client() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="3dac0eed31d1dd3ac4670e501e0677196811f7875e6d1c253c8d874d6903691cbe4f1c27c8468af07bfd7f79b0d6ec4f933b28cb3bb37dcbea18bc2dd8f6e374 libcmis-0.5.2.tar.gz"
+sha512sums="3dac0eed31d1dd3ac4670e501e0677196811f7875e6d1c253c8d874d6903691cbe4f1c27c8468af07bfd7f79b0d6ec4f933b28cb3bb37dcbea18bc2dd8f6e374 libcmis-0.5.2.tar.gz
+0904a529eafa8e1cfdb673e4e7f37150b0b88886cdc32096a89153cb5856d16dc5fee52f39ae5bfea86065b20690a6e14e4b9ad11b36b682c062702b797e82cd icu.patch"
diff --git a/user/libcmis/icu.patch b/user/libcmis/icu.patch
new file mode 100644
index 000000000..6ba63ee7f
--- /dev/null
+++ b/user/libcmis/icu.patch
@@ -0,0 +1,17 @@
+--- a/inc/libcmis-c/repository.h 2018-12-27 14:07:55.000000000 +0100
++++ b/inc/libcmis-c/repository.h 2019-04-21 01:29:46.504373226 +0200
+@@ -28,12 +28,12 @@
+ #ifndef _REPOSITORY_H_
+ #define _REPOSITORY_H_
+
++#include <libxml/tree.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+
+-#include <libxml/tree.h>
+-
+ #include "libcmis-c/libcmis-c-api.h"
+ #include "libcmis-c/types.h"
+