summaryrefslogtreecommitdiff
path: root/user/libfakekey/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libfakekey/APKBUILD')
-rw-r--r--user/libfakekey/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/user/libfakekey/APKBUILD b/user/libfakekey/APKBUILD
index decd8540e..af08c494c 100644
--- a/user/libfakekey/APKBUILD
+++ b/user/libfakekey/APKBUILD
@@ -3,23 +3,21 @@
pkgname=libfakekey
pkgver=0.3
pkgrel=0
-pkgdesc="Library for faking X key-presses from character inputs"
+pkgdesc="Library for faking X11 key presses from character inputs"
url="https://www.yoctoproject.org/software-item/matchbox/"
arch="all"
license="LGPL-2.0+"
depends=""
-makedepends="libx11-dev libxtst-dev"
+makedepends="autoconf automake libtool libx11-dev libxtst-dev"
subpackages="$pkgname-dev"
source="http://git.yoctoproject.org/cgit.cgi/libfakekey/snapshot/libfakekey-$pkgver.tar.gz"
prepare() {
- cd "$builddir"
default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
LIBS="-lX11" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -31,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}