summaryrefslogtreecommitdiff
path: root/user/libidn2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libidn2/APKBUILD')
-rw-r--r--user/libidn2/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/user/libidn2/APKBUILD b/user/libidn2/APKBUILD
index b52ec8ad9..28a56be44 100644
--- a/user/libidn2/APKBUILD
+++ b/user/libidn2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Dan Theisen <djt@hxx.in>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=libidn2
-pkgver=2.3.0
+pkgver=2.3.2
pkgrel=0
pkgdesc="Free implementation of IDNA2008, Punycode, and TR46"
url="https://gitlab.com/libidn/libidn2"
@@ -9,7 +9,7 @@ arch="all"
license="GPL-2.0+ OR LGPL-3.0+"
depends=""
makedepends="libunistring-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+subpackages="$pkgname-dev $pkgname-doc"
source="https://ftp.gnu.org/gnu/libidn/libidn2-$pkgver.tar.gz"
build() {
@@ -19,7 +19,9 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-nls \
+ --disable-valgrind-tests
make
}
@@ -31,4 +33,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a2bf6d2249948bce14fbbc802f8af1c9b427fc9bf64203a2f3d7239d8e6061d0a8e7970a23e8e5889110a654a321e0504c7a6d049bb501e7f6a23d42b50b6187 libidn2-2.3.0.tar.gz"
+sha512sums="958dbf49a47a84c7627ac182f4cc8ea452696cec3f0d1ff102a6c48e89893e772b2aa81f75da8223dfc6326515cca3ae085268fbf997828de9330c3a351152f1 libidn2-2.3.2.tar.gz"