summaryrefslogtreecommitdiff
path: root/user/libimobiledevice/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libimobiledevice/APKBUILD')
-rw-r--r--user/libimobiledevice/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/libimobiledevice/APKBUILD b/user/libimobiledevice/APKBUILD
new file mode 100644
index 000000000..f8bea18dc
--- /dev/null
+++ b/user/libimobiledevice/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=libimobiledevice
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="Library for working with Apple iOS devices"
+url="https://libimobiledevice.org/"
+arch="all"
+license="LGPL-2.1+ AND GPL-2.0+ AND GPL-2.0-only AND MIT"
+depends=""
+makedepends="gnutls-dev libgcrypt-dev libusbmuxd-dev py3-cython python3-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/libimobiledevice/libimobiledevice/releases/download/$pkgver/libimobiledevice-$pkgver.tar.bz2
+ modern-libplist.patch"
+
+build() {
+ ln -s /usr/bin/python3 python
+ export PATH=".:$PATH"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make PATH=".:$PATH" DESTDIR="$pkgdir" install
+}
+
+sha512sums="7b22040552a6561729c79c0846f571b0e608abb7c297567d2ecfdd1718ce86df08a5e34ba51f209bdee96a1917da15e7ba3aaef1d289a951d1d3470b1f89e6a8 libimobiledevice-1.3.0.tar.bz2
+3aa60cdbd9539ac55cdd1e8a6d1860ddfcfec6e692ff9e3b0d4620627f5f373872b819a6008a10e8669ee5772234e4a8a66c1dab89803d401503ee43f51f0a6c modern-libplist.patch"