summaryrefslogtreecommitdiff
path: root/user/libkexiv2/backport.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/libkexiv2/backport.patch')
-rw-r--r--user/libkexiv2/backport.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/user/libkexiv2/backport.patch b/user/libkexiv2/backport.patch
new file mode 100644
index 000000000..93d27e4a8
--- /dev/null
+++ b/user/libkexiv2/backport.patch
@@ -0,0 +1,31 @@
+From 6dce742b86d6f1a42f80017868759a8dca677b1d Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Thu, 19 May 2022 22:44:12 +0200
+Subject: [PATCH] Lower C++ standard from 17 to 14
+
+exiv is not C++17 compatible
+
+It uses e.g. auto_ptr in its headers
+
+CCBUG: 454050
+---
+ CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7f5b065..48ea18b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,6 +13,9 @@ cmake_minimum_required(VERSION ${CMAKE_MIN_VERSION})
+
+ project(libkexiv2 VERSION "5.0.0")
+
++set(CMAKE_CXX_STANDARD 14) # exiv is not compatible with C++ > 14 yet
++set(CMAKE_CXX_STANDARD_REQUIRED ON)
++
+ message(STATUS "----------------------------------------------------------------------------------")
+ message(STATUS "Starting CMake configuration for: ${PROJECT_NAME}")
+
+--
+GitLab
+