summaryrefslogtreecommitdiff
path: root/user/libmpeg2/altivec.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/libmpeg2/altivec.patch')
-rw-r--r--user/libmpeg2/altivec.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/user/libmpeg2/altivec.patch b/user/libmpeg2/altivec.patch
new file mode 100644
index 000000000..7edfaa344
--- /dev/null
+++ b/user/libmpeg2/altivec.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac.bak 2010-05-25 17:12:14.756245990 +0000
++++ b/configure.ac 2010-05-25 17:11:51.629581723 +0000
+@@ -79,11 +79,10 @@
+ CFLAGS="$OPT_CFLAGS $TRY_CFLAGS $CFLAGS"
+ AC_MSG_CHECKING([if <altivec.h> is needed])
+ AC_TRY_COMPILE([],
+- [typedef vector int t;
+- vec_ld(0, (unsigned char *)0);],
++ [vector int t; t = vec_add(t,t);],
+ [have_altivec=yes; AC_MSG_RESULT(no)],
+ [AC_TRY_COMPILE([#include <altivec.h>],
+- [typedef vector int t; vec_ld(0, (unsigned char *)0);],
++ [vector int t; t = vec_add(t,t);],
+ [AC_DEFINE([HAVE_ALTIVEC_H],,
+ [Define to 1 if you have the <altivec.h> header.])
+ have_altivec=yes; AC_MSG_RESULT(yes)],