summaryrefslogtreecommitdiff
path: root/user/libndp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libndp/APKBUILD')
-rw-r--r--user/libndp/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/libndp/APKBUILD b/user/libndp/APKBUILD
new file mode 100644
index 000000000..0ea72e6d4
--- /dev/null
+++ b/user/libndp/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libndp
+pkgver=1.7
+pkgrel=0
+pkgdesc="Library for IPv6 Neighbour Discovery Protocol"
+url="http://libndp.org/"
+arch="all"
+license="LGPL-2.1-only"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://libndp.org/files/libndp-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4aadaf6d7d8b9e57983cba17ce92715cceef6635613c4c5326decb97fb575ce5f5d5586a629645e3605a03e385c6481bfb6c4458216be2bbd36959af62783790 libndp-1.7.tar.gz"